Closed Bug 1020224 Opened 8 years ago Closed 7 years ago

Add son (Songhay) to Gaia languages

Categories

(Firefox OS Graveyard :: Gaia, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1025067

People

(Reporter: dwayne, Unassigned)

References

Details

User Story

+++ This bug was initially created as a clone of Bug #1017918 +++

The hg repo will be created in bug 1017916. Let's add the new locale to languages_all.json

Attachments

(1 file)

Songhay has rapidly got to 100% on Gaia 2.0, but we have no repo and related infrastructure for them.
Depends on: 1020225
No longer depends on: 1017916, 1017918
(Commenting on User Story)
> The hg repo will be created in bug 1017916.

Actual bug for repo creation is bug 1020224 (quite a mess with clones).
(In reply to Francesco Lodolo [:flod] from comment #1)
> (Commenting on User Story)
> > The hg repo will be created in bug 1017916.
> 
> Actual bug for repo creation is bug 1020224 (quite a mess with clones).

Actually bug 1020225, moar noise.
We shouldn't wait too much before merging this one on 2.0.

Is "soŋay" correct, or the first letter must be capitalized?
(In reply to Théo Chevalier [:tchevalier] from comment #3)
> We shouldn't wait too much before merging this one on 2.0.
> 
> Is "soŋay" correct, or the first letter must be capitalized?

Mohomodou would be best to answer that question
Flags: needinfo?(mh)
Flags: needinfo?(mh)
Yes, capitalized if it is the initial word, yes "Soŋay".  
--
If not, lowcase is all right if "soŋay" is used after the first word or inside a sentence. Like "français" or "español".

Let me know if this helps or not. Thanks again for the prompt action.
(In reply to Mohomodou Houssouba from comment #5)
> Yes, capitalized if it is the initial word, yes "Soŋay".  
> --
> If not, lowcase is all right if "soŋay" is used after the first word or
> inside a sentence. Like "français" or "español".
> 
> Let me know if this helps or not. Thanks again for the prompt action.

Thanks Mohomodou, that does help a lot.

This will be displayed in the languages selection list in Settings > Languages. Since this is the first word, we will use "Soŋay", like we currently use "Français"

I'm going to add soŋay to Firefox OS 2.1, and then to Firefox OS 2.0 in a few days.

Thanks for all your hard work on the localization!
Greetings Théo, right deduction – and many thanks for your prompt action and follow-up. It's heartening news indeed. 

I look forward to the next phase. All the best to you!
Comment on attachment 8439530 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/20460

Test error is not related.
Attachment #8439530 - Flags: review?(timdream) → review+
We actually landed that in bug 1025067 :)
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1025067
You need to log in before you can comment on or make changes to this bug.