Closed Bug 1020228 Opened 5 years ago Closed 5 years ago

[Lockscreen] - @2.25x icon scale

Categories

(Firefox OS Graveyard :: Gaia::System::Lockscreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: fang, Assigned: pivanov)

References

Details

Attachments

(3 files)

Attached file lockscreen@2.25x.zip
Updated missing images for lockscreen, base on @2.25x icon, Thanks!

> ./apps/system/style/lockscreen/images/lockscreen_camera@2.25x.png
> ./apps/system/style/lockscreen/images/lockscreen_notification_arrow@2.25x.png
> ./apps/system/style/lockscreen/images/lockscreen_toggle_arrow_left@2.25x.png
> ./apps/system/style/lockscreen/images/lockscreen_toggle_arrow_right@2.25x.png
> ./apps/system/style/lockscreen/images/lockscreen_unlock@2.25x.png
> ./apps/system/style/lockscreen/images/pin_camera@2.25x.png
> ./apps/system/style/media_playback/images/lockscreen-icon-big-next@2.25x.png
> ./apps/system/style/media_playback/images/lockscreen-icon-big-pause@2.25x.png
> ./apps/system/style/media_playback/images/lockscreen-icon-big-play@2.25x.png
> ./apps/system/style/media_playback/images/lockscreen-icon-big-previous@2.25x.png
> ./apps/system/style/media_playback/images/lockscreen-icon-next@2.25x.png
> ./apps/system/style/media_playback/images/lockscreen-icon-pause@2.25x.png
> ./apps/system/style/media_playback/images/lockscreen-icon-play@2.25x.png
> ./apps/system/style/media_playback/images/lockscreen-icon-previous@2.25x.png
Blocks: 1016987
Summary: [Flame][Lockscreen] - @2.25x icon scale → [Lockscreen] - @2.25x icon scale
Attached file patch for Gaia/master
Hey Fang,
can you check this one on real device(I don't have a device yet)
Attachment #8434122 - Flags: ui-review?(fshih)
Attachment #8434122 - Flags: review?(timdream)
Attachment #8434122 - Flags: review?(timdream) → review?(gweng)
Comment on attachment 8434122 [details] [review]
patch for Gaia/master

I think this patch should rely on UI review rather than code review.
Attachment #8434122 - Flags: review?(gweng) → review+
Assignee: nobody → pivanov
Thanks :)

Landed to master:
https://github.com/mozilla-b2g/gaia/commit/908f94fda04462001ece86e6b6c15ad8b05f7526
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Attached image 2014-06-05-03-20-48.png
Hi Pavel,

I've checked this on the real device. The icons look like still a bit fuzzy, and also the entire lock bar shrinks down compared to the rest of UI elements. You can refer to file attached, I took a screenshot of it. Thanks!
Flags: needinfo?(pivanov)
Hey Greg,

Can you help us to find why the images are fuzzy ... as I see there we use canvas for this part of lock screen and maybe the problem is related with the image size ... and for the example:
`lockscreen_toggle_arrow_left.png size in px = 30x30)` and the old version of left arrow is `larrow.png (size in px = 10x20)`

do you have idea?
Flags: needinfo?(pivanov)
According to John Lu who implemented LockScreen visual refreshing, we've encountered weird cases that the fuzzy arrow would sometime disappear after reseting. But I'm sure if we really have a clue about the fuzzy issue. I think to NI him is better.
Flags: needinfo?(jlu)
The fuzzy slider arrows were due to some wrong assumptions/logics in canvas operations. It was fixed in bug 1021479. Both Flame and Nexus 4 should benefit from the fix (for Nexus 4, of course, we needed the 2.25x assets, too).

The relatively shorter width of the slider with Nexus 4 seems like another issue, though. I'll need to spend time investigating it if it's blocking something else.
Flags: needinfo?(jlu)
Attachment #8434122 - Flags: ui-review?(fshih) → ui-review-
You need to log in before you can comment on or make changes to this bug.