need to idl-ize nsIDocumentEncoder.h

RESOLVED WONTFIX

Status

()

Core
Serializers
RESOLVED WONTFIX
17 years ago
15 years ago

People

(Reporter: Brade, Assigned: Brade)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Assignee)

Comment 1

17 years ago
Created attachment 52721 [details]
new file
(Assignee)

Comment 2

17 years ago
Created attachment 52722 [details] [diff] [review]
related changes to remove old header file and build new idl file
(Assignee)

Comment 3

17 years ago
cc peterv and jst for feedback/reviews
The comments in the idl file are just copied over from the .h file.  If you want 
me to change any of them, please let me know.
Status: NEW → ASSIGNED
(Assignee)

Updated

17 years ago
Target Milestone: --- → mozilla0.9.6
Why does this file need to be idl'ized?

Comment 5

17 years ago
This is currently the most approved way of getting output via the html and
plaintext serializers (and eventually other serializers as they're added).
Therefore, it should be accessible to scripts as well as to C++.

If there's some more standard way to get output, please let us know!  Mozilla
has about 7 different ways of doing it, and we're trying to reduce the number of
duplicate APIs for output.  We're not aware of any standard at this point.
A DOM Load and Save spec is currently brewing in the W3C DOM WG, it's not done
soon, but once it is the DOMWirter defined in that spec will be the standard way
of serializing DOM trees.
(Assignee)

Comment 7

17 years ago
push this off for now; publishing doesn't need it at the moment
Target Milestone: mozilla0.9.6 → mozilla0.9.7
(Assignee)

Updated

16 years ago
Target Milestone: mozilla0.9.7 → mozilla0.9.8
(Assignee)

Updated

16 years ago
Target Milestone: mozilla0.9.8 → mozilla1.1
(Assignee)

Updated

16 years ago
Blocks: 124864

Comment 8

16 years ago
*** Bug 124864 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

16 years ago
Keywords: patch
Target Milestone: mozilla1.1alpha → Future
(Assignee)

Comment 9

15 years ago
-->WONTFIX per comment 6 by jst
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.