Unsubscribe link is not working

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: becky, Unassigned)

Tracking

Details

(Whiteboard: [kanban:https://kanbanize.com/ctrl_board/4/219] )

(Reporter)

Description

4 years ago
Hi there,

Please refer to bug 969363, as the same problem is happening again. MoFo sends out a 'please donate' email, and the link to unsubscribe from the mailing list takes the user to a donate page...which is not what we want.

The solution is in bug 969363 so hopefully it won't be too hard to fix!

Thanks!
(Reporter)

Comment 1

4 years ago
Forgot to add the link. The current unsubscribe link in the email is this: https://donate.mozilla.org/unsubscribe

It takes people to the donation page, when it should take people to the unsubscribe page.
Becky - the redirect on our side is still correct (noted below). if it's no longer working, i suspect something has been changed at sendto.mozilla.org. Bobby- can you review that piece similar to what you did last time?

$ curl -I https://donate.mozilla.org/page/unsubscribe
HTTP/1.1 301 Moved Permanently
Server: Apache
X-Backend-Server: pp-web02
Vary: Accept-Encoding
Content-Type: text/html; charset=iso-8859-1
Date: Wed, 04 Jun 2014 16:53:07 GMT
Location: https://sendto.mozilla.org/page/unsubscribe/
Transfer-Encoding: chunked
Connection: Keep-Alive
X-Cache-Info: caching
Flags: needinfo?(bobby)
OS: Mac OS X → All
Hardware: x86 → All
Whiteboard: [kanban:https://kanbanize.com/ctrl_board/4/219]
Looks like the problem is a missing `/page/` part of that unsubscribe URL. Becky, do you know which campaign/email/whatever people are clicking "unsubscribe" on?
Flags: needinfo?(bobby) → needinfo?(becky)
(Reporter)

Comment 4

4 years ago
Hi Bobby - it was a "thank you for donating" email, however there was no subject line so I can't pin point exactly which thank you email it was. It's been over a week since I received the complaint that the unsubscribe button isn't working, and I haven't received any others. Because of that, I think it's fair to say this complaint is a one off - a reply to an old email for instance, when the link wasn't working. 

I am going to close the bug as Fixed, because I think most of the recent emails we've been sending have the updated link. Thanks for everyone's help - sorry to file a bug based on just the one issue!
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(becky)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.