[Settings] The selector of the APN flicks when opening Data settings menu

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Settings
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: isabelrios, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Seen on today's master buri build (06/04):
Gecko-cbe7e9c
Gaia-e94fa5e

STR 
-Go to Settings -> Cellular and Data -> Data Settings and check icon indicating the APN selected

EXPECTED
The APN selector is shown fine

ACTUAL
The APN selector disappears and appears quickly when Data settings menu is open. It happens every time that user opens that menu

This is not happening in 1.3, so adding regression keyword
We need a screenshot of the bug here.
Keywords: qawanted
(Reporter)

Comment 2

4 years ago
Attaching a video file so you can see how the icon is selected, deselected and selected again, this happens very quickly please pay attention.

This bug would be a certification blocker, so nominating to 2?
blocking-b2g: --- → 2.0?
(Reporter)

Comment 3

4 years ago
Created attachment 8434779 [details]
APN selecion.3gp
(In reply to Isabel Rios [:isabel_rios] from comment #2)
> Attaching a video file so you can see how the icon is selected, deselected
> and selected again, this happens very quickly please pay attention.
> 
> This bug would be a certification blocker, so nominating to 2?

This flick is because of the APN selection process. Let me explain myself better. The panel logic underneath selects the APN in the list that is being in use by the RIL plumbing and switches the selected radio button. This happens every time the panel gets open so if the user opens the panel for a first time and select the APN 'A', the second time the user opens the panel the APN 'A' is selected and will be selected again once logic underneath checks that the APN 'A' is being in use by the RIL plumbing. The flick is because the logic underneath switches the radio button again. This flick is not seen if the user opens the settings app and opens the data APN panel. The flick would be seen if the users open the data APN panel -at least- a couple of times (without closing the settings app). IMHO this is not a bug. We added this in bug 962453, so this also happens in v1.3.

Updated

4 years ago
Keywords: qawanted, regression
Thanks Jose Antonio for the explanation, doing more testing you are always right :)
Unagi- 1.3 and 2.0 builds are suffering the issue.

However, Open II, Open C and Sora with 1.3 are not showing it... We need time to investigate the reason of the different behaviour between these devices before making a decission with this bug.
(In reply to José Antonio Olivera Ortega [:jaoo] from comment #4)
> (In reply to Isabel Rios [:isabel_rios] from comment #2)
> > Attaching a video file so you can see how the icon is selected, deselected
> > and selected again, this happens very quickly please pay attention.
> > 
> > This bug would be a certification blocker, so nominating to 2?
> 
> This flick is because of the APN selection process. Let me explain myself
> better. The panel logic underneath selects the APN in the list that is being
> in use by the RIL plumbing and switches the selected radio button. This
> happens every time the panel gets open so if the user opens the panel for a
> first time and select the APN 'A', the second time the user opens the panel
> the APN 'A' is selected and will be selected again once logic underneath
> checks that the APN 'A' is being in use by the RIL plumbing. The flick is
> because the logic underneath switches the radio button again. This flick is
> not seen if the user opens the settings app and opens the data APN panel.
> The flick would be seen if the users open the data APN panel -at least- a
> couple of times (without closing the settings app). IMHO this is not a bug.
> We added this in bug 962453, so this also happens in v1.3.

Looks like this is an old regression from 1.3, so would not block 2.0 on this one. If we are able to fix this soon enough please request approval for uplift
blocking-b2g: 2.0? → -
(In reply to bhavana bajaj [:bajaj] from comment #6)
> (In reply to José Antonio Olivera Ortega [:jaoo] from comment #4)
> > (In reply to Isabel Rios [:isabel_rios] from comment #2)

> Looks like this is an old regression from 1.3, so would not block 2.0 on
> this one. If we are able to fix this soon enough please request approval for
> uplift

We could provide a fix for this issue. Actually it's not a bug but something it might confuse the user. Better fix it IMHO. I'll provide a fix as soon as possible.
Assignee: nobody → josea.olivera
Created attachment 8445011 [details] [review]
Pointer to Github PR https://github.com/mozilla-b2g/gaia/pull/20918

This patch could fix the issue. Isabel, let me know if it works for you. Thanks!
Attachment #8445011 - Flags: feedback?(isabelrios)
Flags: needinfo?(isabelrios)
(Reporter)

Comment 9

4 years ago
Feedback given offline, investigating another possible solution.
Thanks Jose Antonio!
Flags: needinfo?(isabelrios)
(Reporter)

Updated

3 years ago
Attachment #8445011 - Flags: feedback?(isabelrios) → feedback?
(Reporter)

Comment 10

3 years ago
As per comment 9, removing feedback flag
I'm not working on this so I'm leaving it unassigned so someone else can work on it. Sorry. Thanks!
Assignee: jaoo → nobody
After checking the behaviuor in master branch. I cannot reproduce the flicker anymore.
I will set the status as WFM. Please reopen if you think so.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.