Closed Bug 1020408 Opened 5 years ago Closed 5 years ago

Hide old homescreen in version 2.0 for mobile phones

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

All
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.0+, b2g-v2.0 fixed, b2g-v2.1 fixed)

RESOLVED FIXED
2.0 S4 (20june)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- fixed
b2g-v2.1 --- fixed

People

(Reporter: crdlc, Assigned: kgrandon)

References

Details

(Whiteboard: [systemsfe],[p=2])

Attachments

(1 file)

46 bytes, text/x-github-pull-request
yurenju
: review+
Details | Review
I think that we have to hide the old homescreen app in version 2.0 at least for mobile phones. I don't know if tablets support it or not. If tablets or other devices will use the old homescreen, perhaps, we should implement it at build level thought. 

How could we hide the old homescreen?
We could change the role in the manifest file from homescreen to system.
Whiteboard: [systemsfe]
Yuren - do you have any preference as to how we handle this? My initial thoughts are that we could change the manifest in the build step to have role=system for non tablet devices..

On second thought I may have just broken tablets completely with landing the vertical homescreen. Let me make sure I didn't do that yet :)
Yuren - Please see comment #1, thanks!
Flags: needinfo?(yurenju.mozilla)
Duplicate of this bug: 1021440
blocking-b2g: --- → 2.0?
Duplicate of this bug: 1021449
not sure what you mean since I don't see homescreen app on current home2, but we have "homescreen.appName" settings value for different device type. For example, tv used "homescreen-stingray" app for homescreen[1].

Gary will update customzation page on MDN[2] for this setting.

[1] https://github.com/mozilla-b2g/gaia/blob/master/build/config/tv/settings.json
[2] https://developer.mozilla.org/en-US/Firefox_OS/Developing_Firefox_OS/Market_customizations_guide
Flags: needinfo?(yurenju.mozilla)
(In reply to Cristian Rodriguez (:crdlc) from comment #0)
> I think that we have to hide the old homescreen app in version 2.0 at least
> for mobile phones. I don't know if tablets support it or not. If tablets or
> other devices will use the old homescreen, perhaps, we should implement it
> at build level thought. 
> 
> How could we hide the old homescreen?
> We could change the role in the manifest file from homescreen to system.

Yes, currently we can customize default Homescreen APP through 'setting.json', please refer to the following links.

https://developer.mozilla.org/en-US/Firefox_OS/Developing_Firefox_OS/Market_customizations_guide#Customize_default_Homescreen_APP
QA Whiteboard: [VH-FL-blocking+]
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
Whiteboard: [systemsfe] → [systemsfe],[p=2]
Target Milestone: --- → 2.0 S3 (6june)
Attached file Github pull request
Yuren - I was thinking of something like this, what do you think?
Attachment #8436095 - Flags: review?(yurenju.mozilla)
blocking-b2g: 2.0? → 2.0+
Comment on attachment 8436095 [details] [review]
Github pull request

I didn't have enough context for this change but Thanks Tim to help me understand the story about migration for homescreen and browser (both using "system" role for this purpose), so that's good to me, thanks!
Attachment #8436095 - Flags: review?(yurenju.mozilla) → review+
Landed: https://github.com/mozilla-b2g/gaia/commit/8e803bf91ce792439cc6c11dff657240a4bd8df8
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: 2.0 S3 (6june) → 2.0 S4 (20june)
Flags: in-moztrap-
You need to log in before you can comment on or make changes to this bug.