[B2G][Contacts][Export] User is brought back to contacts list instead of export list

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Contacts
P3
normal
RESOLVED WONTFIX
4 years ago
4 months ago

People

(Reporter: RolandK, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(tracking-b2g:backlog, b2g-v1.4 unaffected, b2g-v2.0 affected)

Details

(Whiteboard: permafail)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8434362 [details]
logcat

Description:
When the user completes an operation involving exporting contacts they should be brought back to the export contacts screen, not their contacts list.

Setup Steps:
1) Have contacts on the DuT 
2) Have a memory card in the DuT 

Repro Steps:
1) Update a Flame device to BuildID: 20140604040204
2) Contacts > Settings > Export Contacts > Memory card
3) Select a contact, Export
4) Observe user is brought back to their contacts list and not the export screen

Actual:
User is brought back to their contacts list and not the export screen

Expected:
The user returns to export contacts

v2.0 Environmental Variables:
Device: Flame v2.0 MOZ RIL
BuildID: 20140604040204
Gaia: 1d4f6f7312882e78b57971152de75d1281a26187
Gecko: 668f29cd71b3
Version: 32.0a1
Firmware Version: V10G-2

Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/9795/
See attached: logcat
(Reporter)

Comment 1

4 years ago
This issue does reproduce on the latest v2.0 Buri build:

v2.0 Environmental Variables:
Device: Buri v2.0 MOZ RIL
BuildID: 20140604040204
Gaia: 1d4f6f7312882e78b57971152de75d1281a26187
Gecko: 668f29cd71b3
Version: 32.0a1
Firmware Version: V1.2-device.cfg

-

This issue does not reproduce on the latest v1.4 Buri build:

v1.4 Environmental Variables:
Device: Buri v1.4 MOZ RIL
BuildID: 20140604000202
Gaia: 0c16adced7c51f795ef250aebe184f60b6a9b987
Gecko: 04216748e6c1
Version: 30.0
Firmware Version: V1.2-device.cfg

-

This issue does not reproduce on the latest v1.4 Flame build:

v1.4 Environmental Variables:
Device: Flame v1.4 MOZ RIL
BuildID: 20140604000202
Gaia: 0c16adced7c51f795ef250aebe184f60b6a9b987
Gecko: 04216748e6c1
Version: 30.0
Firmware Version: V10G-2
UX - Is this an intentional UX change or a bug?
Flags: needinfo?(firefoxos-ux-bugzilla)

Comment 3

4 years ago
Flagging Carrie on Comms. Carrie, please reassign as necessary.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(cawang)
This is the original UX design because we already provide a notification for users and actually we didn't create any kind of "exported" list. I think it's worth to change the behavior in the future. I'll note it down. Thanks!
Flags: needinfo?(cawang)
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Whiteboard: [2.0-flame-test-run-1] → [2.0-flame-test-run-1], [2.0-flame-test-run-2]
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+][lead-review+] → [QAnalyst-Triage?][lead-review+]
Flags: needinfo?(ktucker)
Whiteboard: [2.0-flame-test-run-1], [2.0-flame-test-run-2] → permafail
QA Whiteboard: [QAnalyst-Triage?][lead-review+] → [QAnalyst-Triage+][lead-review+]
Flags: needinfo?(ktucker)
[Tracking Requested - why for this release]: This test case has failed for 3 releases (aka "permalfail"). Let's choose between putting a high priority on this bug, or removing the test case from Moztrap.
tracking-b2g: --- → backlog
Per comms triage
Priority: -- → P3

Comment 7

4 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.