Closed Bug 10206 Opened 21 years ago Closed 21 years ago

[PP] cookie viewer hangs on netcenter cookies

Categories

(Core :: Networking: Cookies, defect, P3)

PowerPC
Windows NT
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: morse, Assigned: morse)

References

()

Details

Go to home.netscape.com and let it set some cookies (i.e., don't have cookies
disabled).  Then do edit/wallet/display-cookies to bring up cookie viewer.  The
cookie viewer screen comes up blank and the entire machine hangs (needs a
reboot).  The debug window is looping on the message "reading file".

The cookie viewer works fine if there are no cookies.  It also works fine when
displaying cookies that have been set from other sites (e.g., www.nytimes.com).
But if cookies have been set by netcenter we encounter this hang.

Problem does not occur on windows.  Haven't tested it on unix but I presume it
is ok there as well.  Appears to be a mac-only bug.
Status: NEW → ASSIGNED
Target Milestone: M9
Target Milestone: M9 → M10
Not going to make it by M9 -- moving to M10.

Paul, have you checked this recently to determine if it is still a problem?
Summary: [pp] cookie viewer hangs on netcenter cookies → [PP] cookie viewer hangs on netcenter cookies
display cookies doesn't work at all on Mac, bug 9773
Paul, now that bug 9773 has been closed (works for dan at least), does this bug
still happen?
cookies aren't working on my build, I will test when they are working again.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
this is OK, though the display signons screen has regressed a bit (jay filed a
bug earlier today that looks like the same problem).

Marking this one fixed.
You need to log in before you can comment on or make changes to this bug.