jobsearch.gov.au - clicks on the country map don't turn on check boxes right of the map

RESOLVED INVALID

Status

Tech Evangelism Graveyard
English Other
RESOLVED INVALID
16 years ago
3 years ago

People

(Reporter: Marcel Kunath, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.4) Gecko/20010913
BuildID:    2001091303

I am trying to look up jobs and I go to the following page:
http://www.jobsearch.gov.au/map_common.asp?area=sydn&st=0&

I try to select certain country area with the use of the mouse as I move it
across the map. The areas I am over are suppose to turn white. Once a area is
clicked it's referring checkbox on the right is supposed to be marked as well.
The highlighting of the areas in the map only works sometimes and the checkbox
turn on never works.

Reproducible: Always
Steps to Reproduce:
1. Visit page: http://www.jobsearch.gov.au/map_common.asp?area=sydn&st=0&
2. Move mouse over the map. 
3. Sometimes the area the mouse is over does not become highlighted (white).
4. Click an area inside the map.
5. The checkbox on the right should now be marked as "checked" but it is not.

Actual Results:  The feature of mouse clicks does not function. The use of the
map is not possible. A person who is unfamiliar with the map does not know which
area inside the map has what name to it.

Expected Results:  Try the same thing in IE. It works in IE.

I know it's a fancy feature but a quite useful one for people who understand a
map but are unfamiliar with the actual names of the areas. I just moved here to
Sydney and it would certainely help me a lot.

Mozilla rocks! Keep up the good work.

Comment 1

16 years ago
Thank you for such a well-written bug report!

Confirming bug with Mozilla trunk binary 20011004xx WinNT, Linux.
OS : Win98 --> All. No errors in JavaScript Console. 

Note the map is a Shockwave Flash plug-in.  
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 98 → All

Comment 2

16 years ago
It looks to me like the site authors are trying to use LiveConnect 
to script the Flash plug-in. Here is a sample of the HTML, where 
they document.write the plug-in. Note <PARAM NAME=swLiveConnect VALUE=true>: 


var FlashEnabled;
FlashEnabled = false;

if (navigator.mimeTypes && navigator.mimeTypes["application/x-shockwave-flash"] 
&& navigator.mimeTypes["application/x-shockwave-flash"].enabledPlugin && 
navigator.plugins && navigator.plugins["Shockwave Flash"])
        FlashEnabled = true;



if (FlashEnabled){
	document.write("<OBJECT 
classid=\"clsid:D27CDB6E-AE6D-11cf-96B8-444553540000\" 
codebase=\"http://active.macromedia.com/flash2/cabs/swflash.cab#version=4,0,0,0\
" ID=Opening_test1 WIDTH=230 HEIGHT=210>");
	document.write("<PARAM NAME=movie VALUE=\"flash/map_syd.swf\">");
	document.write("<PARAM NAME=quality VALUE=high>");
	document.write("<PARAM NAME=\"bgcolor\" VALUE=\"#D7EAEA\">");
	document.write("<PARAM NAME=swLiveConnect VALUE=true>");
	document.write("<EMBED src=\"flash/map_syd.swf\" NAME=Opening_test1 
quality=high bgcolor=#D7EAEA WIDTH=230 HEIGHT=210 swLiveConnect=true 
TYPE=\"application/x-shockwave-flash\" 
PLUGINSPAGE=\"http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Ver
sion=ShockwaveFlash\">");
	document.write("</EMBED>");
	document.write("</OBJECT>");

Comment 3

16 years ago
Here is some of the browser detection:

  var InternetExplorer = navigator.appName.indexOf("Microsoft") != -1;
  var IEtag = document.all;



If you mouseover lines of text like "Central Coast" in the HTML, 
the corresponding region of the map is supposed to light up in white.
Here is an example of how these events are supposed to be communicated
via JavaScript to the plug-in (named "Opening_test1"; see above).


function texthover(number){
  if (FlashEnabled){
    if (number == 99){ 
      //it is the country wide highlite
      var Opening_test1Obj = InternetExplorer ? Opening_test1 :                                                                                                                                                                                                 
                                                document.Opening_test1;

      for (i=1;i<10;i++){
        Opening_test1Obj.TGotoLabel("_level0:/map" + i,"white");
        if (IEtag) {
          eval("document"+ scope +".chkboxtext" + number).style.color =                                                                                                                                 
                                                                texthovercolor;
        }				
      }
    }else{
      if (store[number] == 0) {
        var Opening_test1Obj = InternetExplorer ? Opening_test1 :                                                   
                                                  document.Opening_test1;
        Opening_test1Obj.TGotoLabel("_level0:/map" + number,"white");
        Opening_test1Obj.TGotoFrame("_level0:/text",number-1);
        if (IEtag) {
          eval("document"+ scope +".chkboxtext" + number).style.color =                                                                 
                                                                texthovercolor;
        }
      }
    }	
  }
}

Comment 4

16 years ago
You can trigger this highlighting yourself by going to the URL bar
and keying

                    javascript: texthover(1);


This works in NN4.7 and IE4.7, but not in Mozilla. I think this is
because of the LiveConnect scripting used at this site. Mozilla 
only supports XPConnect scripting for plug-ins, and I believe that
Flash supports this. So perhaps all the site authors have to do is
change the <PARAM NAME=swLiveConnect VALUE=true> above. - ? 


Reassigning to Tech Evangelism -
Component: Javascript Engine → English: Non-US
Product: Browser → Tech Evangelism
Version: other → unspecified

Comment 5

16 years ago
cc'ing Arun to make sure about this - 
Assignee: rogerl → momoi
QA Contact: pschwartau → jonrubin

Comment 6

16 years ago
We need to 2 things.

1. Get the correct page for flash served when accessing with 
   Mozilla-based browsers. The server sends different pages to
   IE, NN4 and Mozilla/N6. For example, if you connect with NN4, 
   you at least get a flash image map loaded and is able to
   get the text info by hovering the mouse over various parts.
   This is possible without any modification, to a page that is meant
   for NN4. With the page meant for IE, no such effect is observed.
   With the 3rd types of page, there is no plugin loading script 
   in it.
2. Once you get the right page served, then we need to get
   the mouseover effect on the region names on the right of
   the image map working correctly. 

   

Comment 7

16 years ago
> For example, if you connect with NN4, you at least get a 
> flash image map loaded and is able to get the text info 
> by hovering the mouse over various parts. This is possible 
> without any modification, to a page that is meant for NN4.

I should clarify this remark. What I meant is that if you save
the problem page using NN4, and then view it using Mozilla/NS6.x,
you at least will be able to get the flash map loaded and then 
will be able to see the mouse over effect without making
any modification to that file. You still don't get the mouse
over effect on the region names on the right of the map, however.

Comment 8

15 years ago
Doesn't work in 20030313 OSX either.
Severity: minor → normal
Hardware: PC → All
Summary: Mouse clicks on the country map don't turn on check boxes right of the map → jobsearch.gov.au - clicks on the country map don't turn on check boxes right of the map

Comment 9

15 years ago
Mass reassigning English-Other bugs to general default assignees.
Assignee: momoi → english-other
QA Contact: jonrubin → english-other

Comment 10

13 years ago
Closing:
"HTTP 404 - File not found
Internet Information Services"

If you can find the page again, please open a new bug if the problem persists.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.