[B2G][Tarako][Music] User sees an error message briefly when attaching music to sms

RESOLVED DUPLICATE of bug 943976

Status

RESOLVED DUPLICATE of bug 943976
5 years ago
5 years ago

People

(Reporter: rpribble, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v1.3T affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 8434588 [details]
Logcat.txt

Description:
If the user sends a song via sms, they will briefly see the message 'you have exceeded the maximum length' message referring to the character length, when the message is empty.

Repro Steps:
1) Update device to BuildID: 20140602014001
2) Launch music app and play a song
3) Tap the share icon in the upper right corner
4) Select 'messages'

Actual:
User sees an error message briefly about exceeded max character length.

Expected:
User has not exceeded character length, no message is displayed.

Environmental Variables:
Device: Tarako 1.3T
BuildID: 20140602014001
Gaia: 335486c42498fa7a93c21e4d6121199728602ab8
Gecko: 55e4d83019e5
Version: 28.1
Firmware Version: SP6821a-Gonk-4.0-4-29

Notes: 

Repro frequency: 100%
See attached: Video
(Reporter)

Comment 1

5 years ago
Qawanted to check Buri v1.3.
Keywords: qawanted
The music shouldn't be able to share to SMS.  If you try to attach music from SMS, it will give you the error of the music file is too large.  This is a good catch.
blocking-b2g: --- → 1.3T?
Note: trying to share via email will give you the appropriate message that the file size is too large.

Comment 4

5 years ago
Share an audio file from Music to SMS or Email are both correct behaviours, the difference is the size limitation, I believe Email can attach larger files than SMS, and once the shared file is too large, both of them should popup the message like "file is too large", and if the message is about the exceeded max character length, then it should be a bug in SMS.
Component: Gaia::Music → Gaia::SMS
This is bug 943976, that landed in v2.0 only.

The behavior exists in some way since version 1.1
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 943976

Updated

5 years ago
Keywords: qawanted

Updated

5 years ago
blocking-b2g: 1.3T? → ---
Spoke with Julien.  He's right.  It's a duplicate.
You need to log in before you can comment on or make changes to this bug.