Remove /about -> /contribute redirects for locales

VERIFIED FIXED

Status

www.mozilla.org
L10N
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: stephend, Assigned: jgmize)

Tracking

Production

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

STR (thanks to Theo for the find!):

Load https://www.mozilla.org/fr/about

Actual Results:

You get a 301 from there -> https://www.mozilla.org/fr/about/, which then additionally 301s -> https://www.mozilla.org/fr/contribute

Expected Results:

I'm not sure, but don't we have a French version of the About page?

You can see the breakdown here: http://www.webpagetest.org/result/140605_VS_1C6/
(In reply to Stephen Donner [:stephend] from comment #0)

> I'm not sure, but don't we have a French version of the About page?
> 

We do :)
(Assignee)

Comment 3

4 years ago
According to bug 885848 this is intentional. The redirects in https://github.com/mozilla/bedrock/blob/master/etc/httpd/global.conf#L369-L372 appear to be functioning as expected. I'm going to go ahead and resolve this as invalid; if I'm missing something please reopen.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
(In reply to Josh Mize [:jgmize] from comment #3)
> According to bug 885848 this is intentional. The redirects in
> https://github.com/mozilla/bedrock/blob/master/etc/httpd/global.conf#L369-
> L372 appear to be functioning as expected. I'm going to go ahead and resolve
> this as invalid; if I'm missing something please reopen.

Hmm, as far as I understand, bug 885848 was about removing the old PHP page here http://viewvc.svn.mozilla.org/vc/projects/mozilla.org/trunk/about/, not the bedrock one.

We have localized versions of this page https://www.allizom.org/en-US/about/ we should expose them
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
(Assignee)

Comment 5

4 years ago
Ah, thanks :tchevalier, that's what I was missing. You said "localized versions", plural: other than fr, what locales do we need to disable this redirect for?
Flags: needinfo?(tchevalier)
(In reply to Josh Mize [:jgmize] from comment #5)
> Ah, thanks :tchevalier, that's what I was missing. You said "localized
> versions", plural: other than fr, what locales do we need to disable this
> redirect for?

Currently, the page is translated and activated on production for all the locales that are green on the "activated" column here http://l10n.mozilla-community.org/~pascalc/langchecker/?locale=all&website=0&file=mozorg/about.lang

But can't we disable redirect for all locales and fallback to English, like on the other pages? Because as you probably know, we may add new locales for this page at any time (when we get new translations)
Flags: needinfo?(tchevalier)
(Assignee)

Updated

4 years ago
Assignee: nobody → jmize
(Assignee)

Comment 7

4 years ago
Created attachment 8434631 [details] [review]
bedrock pr 2079
(Assignee)

Updated

4 years ago
Summary: /fr/about redirects to /contribute → Make /about -> /contribute redirect specific to locales that have not been translated
Seems to me the correct move here is to remove the redirects from /about/ to /contribute/ completely. From the old but it seems it was a temporary fix so that we could continue deleting all the things from the old .org repo. Since the bedrock /about/ page is well translated I think we should just point all locales to it and let bedrock sort it out.
Hi Jenn and Pascal. What is your input on the above?
Flags: needinfo?(pascalc)
Flags: needinfo?(jbertsch)
(In reply to Paul McLanahan [:pmac] from comment #8)
> Seems to me the correct move here is to remove the redirects from /about/ to
> /contribute/ completely. From the old but it seems it was a temporary fix so
> that we could continue deleting all the things from the old .org repo. Since
> the bedrock /about/ page is well translated I think we should just point all
> locales to it and let bedrock sort it out.

That sounds right to me.
Flags: needinfo?(jbertsch)
Can we get tests for this, pretty please? :-)
I agree with Paul, we shouldn't redirect any about page to contribute today, this was done in the past while we were sorting out the merging of mozilla/.org/.com/europe/messaging about pages into a single set of about pages, this is done and largely localized, today the redirect is no longer needed and should be removed.
Flags: needinfo?(pascalc)
(Assignee)

Updated

4 years ago
Summary: Make /about -> /contribute redirect specific to locales that have not been translated → Remove /about -> /contribute redirects for locales

Comment 13

4 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/db1c0d5879f06f0359ef22957b922abe41e5248b
Remove /about->/contribute redir: fix bug 1020705

https://github.com/mozilla/bedrock/commit/e3ab61f922be077db07a67ba4141e454c7c2784a
Merge pull request #2079 from jgmize/locale-specific-about-contribute-redirect

Remove /about->/contribute redirects: fix bug 1020705

Updated

4 years ago
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
Wasn't able to test the full extent of the patch (i.e. all locales, regression-testing, etc.), but the use-case in comment 0 now works, for both Theo and I.

http://www.webpagetest.org/result/140619_CD_X/

As well as using IE 11 on Windows 7, and  Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:33.0) Gecko/20100101 Firefox/33.0

Verified FIXED on prod.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.