[Dialer][Flame] Enter more than 19 digits in dialer, back delete button moved couple pixels to the left

VERIFIED FIXED in Firefox OS v2.0

Status

Firefox OS
Gaia::Dialer
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: ericcc, Assigned: paco)

Tracking

unspecified
2.0 S4 (20june)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(feature-b2g:2.0, b2g-v2.0 verified, b2g-v2.1 verified)

Details

Attachments

(5 attachments)

(Reporter)

Description

4 years ago
Created attachment 8434649 [details]
Merged.png

### STR
1. Enter 19 digits in dialer
2. Enter 1 more digit.
3. <ISSUE> back delete button moved couple pixels to the left.

### Reproduce rate 
100% on Flame and Buri

### Version Flame
Gaia      a38a6a5c6fabc97dd16d5360632b5ac5c7e06241
Gecko     https://hg.mozilla.org/mozilla-central/rev/951e3a671279
BuildID   20140604160202
Version   32.0a1
(Reporter)

Comment 1

4 years ago
Created attachment 8434650 [details]
19digits.png
(Reporter)

Comment 2

4 years ago
Created attachment 8434652 [details]
20digits.png

Updated

4 years ago
Blocks: 950760
feature-b2g: --- → 2.0
Germán: Can you or Paco take a look at this?
Assignee: nobody → gtorodelvalle
Target Milestone: --- → 2.0 S4 (20june)
Assignee: gtorodelvalle → pacorampas
(Assignee)

Comment 4

4 years ago
Created attachment 8437477 [details] [review]
patch in github
Attachment #8437477 - Flags: review?(anthony)
Eric: I can't reproduce this on today's master build. Can you retest?
Flags: needinfo?(echang)
(Reporter)

Comment 6

4 years ago
I found that is not happening exactly between 19-20, sometimes 21-22 or 22-23... 
https://www.youtube.com/watch?v=_8BqbYEx0Ls

### Flame aurora v2.0 (same on master v2.1)
Gaia      8d865839d932bfbd5e157f376f74d8cb12bfdd51
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/1d4046a8cb6c
BuildID   20140610000223
Version   32.0a2
ro.build.version.incremental=104
ro.build.date=Fri Jun  6 17:35:09 CST 2014
t2m.sw.version=B1TC400110H0

### Buri master v2.1 also has that issue
Gaia      e0c637f14265291ed81934058ec1cc019612127c
Gecko     https://hg.mozilla.org/mozilla-central/rev/13be61241671
BuildID   20140610160204
Version   33.0a1
ro.build.version.incremental=324
ro.build.date=Thu Dec 19 14:04:55 CST 2013
Flags: needinfo?(echang)
Comment on attachment 8437477 [details] [review]
patch in github

Thanks!

You'll need to ask for approval to uplift this to 2.0.
Attachment #8437477 - Flags: review?(anthony) → review+

Updated

4 years ago
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → affected
(Assignee)

Comment 8

4 years ago
Comment on attachment 8437477 [details] [review]
patch in github

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: Wrong UX
[Testing completed]: yes
[Risk to taking this patch] (and alternatives if risky): no risk
[String changes made]:
Attachment #8437477 - Flags: approval-gaia-v2.0?
Comment on attachment 8437477 [details] [review]
patch in github

low risk, polish change. Approving for uplift.
Attachment #8437477 - Flags: approval-gaia-v2.0? → approval-gaia-v2.0+

Updated

4 years ago
Keywords: checkin-needed
Master: https://github.com/mozilla-b2g/gaia/commit/5b4b4fc17a8e4a513a977f7062ea3e65d26ce268

Will uplift to v2.0 per the usual practices once this sticks on master.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-b2g-v2.1: affected → fixed
Keywords: checkin-needed
Resolution: --- → FIXED

Updated

4 years ago
QA Contact: lolimartinezcr
Tested and working
Hamachi
2.1
Gecko-a3c4c53
Gaia-5f9f64a

Hamachi 
2.0
Gecko-3bfc06b
Gaia-5e14503
Status: RESOLVED → VERIFIED

Updated

3 years ago
status-b2g-v2.0: fixed → verified
status-b2g-v2.1: fixed → verified

Comment 13

3 years ago
Created attachment 8529568 [details]
VIDEO0062_Compress.MP4

This issue has been successfully verified on Flame 2.0:
Gaia-Rev        db2e84860f5a7cc334464618c6ea9e92ff82e9dd
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/211eae88f119
Build-ID        20141126001202
Version         34.0
Device-Name     flame
FW-Release      4.4.2


This issue has been successfully verified on Flame 2.1:
Gaia-Rev        1bdd49770e2cb7a7321e6202c9bf036ab5d8f200
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/db893274d9a6
Build-ID        20141125001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
You need to log in before you can comment on or make changes to this bug.