[Flame][V1.4][Camera]The preview screen will flicker when switch between camera mode and video mode.

RESOLVED DUPLICATE of bug 998019

Status

Firefox OS
Gaia::Camera
RESOLVED DUPLICATE of bug 998019
4 years ago
3 years ago

People

(Reporter: panda67231, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: bamboo)

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 8434738 [details]
Camera2.mp4

[1.Description]:
Switch the camera mode and video mode in front camera, the screen will flicker,it does not smoothly.
Attach the video:[Camera2.mp4]
Attach the logs: [bugreport_Camera2.txt & logcat_Camera2.txt]
Happened time:9:46AM

[2.Testing Steps]: 
1. Launch camera.
2. Switch to front camera.
3. Switch camera mode and video mode.


[3.Expected Result]: 
3. The screen should not  flicker, it should be smoothly. 

[4.Actual Result]: 
3. The preview screen will flicker,it does not show smoothly.

[5.Reproduction build]: 
Gaia        7709936aeb21859d1607dbd038489493803bb085
Gecko     https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/5bf038fae0f1
BuildID    20140522160202
Version    30.0

[6.Reproduction Frequency]: 
Always Recurrence,5/5
(Reporter)

Comment 1

4 years ago
Created attachment 8434740 [details]
bugreport_Camera2.txt
(Reporter)

Comment 2

4 years ago
Created attachment 8434742 [details]
logcat_Camera2.txt
I thought we did some fade-in magic to make this look nicer.
Flags: needinfo?(jdarcangelo)
Blocks: 1015220
Status: UNCONFIRMED → NEW
Ever confirmed: true
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 998019
Flags: needinfo?(jdarcangelo)
You need to log in before you can comment on or make changes to this bug.