Closed Bug 1020994 Opened 6 years ago Closed 4 years ago

Unable to add a bookmark to homescreen

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.0 affected)

RESOLVED WONTFIX
Tracking Status
b2g-v2.0 --- affected

People

(Reporter: viorela, Unassigned)

References

Details

(Keywords: regression, Whiteboard: [2.0-flame-test-run-2])

# Prerequisities:
Connect to network

#STR:
1. Launch Browser app
2. In the url bar type: http://mozqa.com/data/firefox/layout/mozilla.html
3. Press Bookmark button
4. Tap Add to homescreen
5. Enter a name in the website name field - Add link page (E.g. gaia1234)
6. Tap Add to Home Screen
7. Touch home button to get to Homescreen
8. Search for the bookmark you just added on homescreen

#Expected results:
The bookmark title is displayed on Homescreen

#Actual results
The bookmark title is not displayed on Homescreen, it is not installed

#ENV:
Device: Flame
Gaia      d2cfef555dabab415085e548ed44c48a99be5c32
Gecko     https://hg.mozilla.org/mozilla-central/rev/51b428be6213
BuildID   20140605040202
Version   32.0a1
ro.build.version.incremental=94
ro.build.date=Tue May 20 09:29:20 CST 2014


I was able to reproduce the failure manually and also by running the automated test.
This is not reproducible on v1.4.

Jenkins report: http://selenium.qa.mtv2.mozilla.com:8080/job/b2g.flame.mozilla-central.ui.non-smoketest/52/HTML_Report/
Kevin - Is this use case currently supported on the vertical homescreen?
blocking-b2g: --- → 2.0?
Component: Gaia::Browser → Gaia::Homescreen
Flags: needinfo?(kgrandon)
Yes it was. This issue is not reproducible in this version:
Gaia      0410f2a60cd68ebf0e3f5151404fefe38d1ad5df
Gecko     https://hg.mozilla.org/integration/b2g-inbound/rev/c9f413c5774e
BuildID   20140604122116
Version   32.0a1
This use-case is supported on the vertical homescreen. 

Viorela - Can you confirm that this was reproduced on the vertical homescreen? The python test, test_browser_tabs.py, still tests the old homescreen AFAIK. I'm also not able to reproduce this on the vertical homescreen.
Flags: needinfo?(kgrandon) → needinfo?(viorela.ioia)
QA Wanted to confirm comment 3 that this can't be reproduced on the vertical homescreen.
This can't be reproduced on the vertical screen, only on the regular one. 
Indeed, test_browser_bookmark.py it is not updated to use the new screen yet.
Flags: needinfo?(viorela.ioia)
Clearing the nom - we have no plans to formally support the old homescreen in 2.0.
blocking-b2g: 2.0? → ---
Keywords: qawanted
Duplicate of this bug: 1021488
Closing this bug as test_browser_bookmark.py has been updated since. It seems to be not reproducible manually anymore. See bug 1019900 for details.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME
Wait - this is talking about the old homescreen, not the new one.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Whiteboard: [2.0-flame-test-run-2]
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
I reproduce the issue using Flame device:
Gaia   a47ecb6368c015dd72148acde26413fd90ba3136
SourceStamp 757931d0149e
BuildID 20140904000203
Version 34.0a2
2.1 Aurora

Adding a website to home screen does not work, tapping the button "Add to Home SCreen" does not have any effect.
Mass update: Resolve wontfix all issues with legacy homescreens.

As of 2.6 we have a new homescreen and having these issues open is confusing. All issues will block bug 1231115 so we can use that to re-visit any of these if needed.
Blocks: 1231115
Status: REOPENED → RESOLVED
Closed: 6 years ago4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.