If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

While closing FF, warning text may not shown in lv

RESOLVED FIXED

Status

Mozilla Localizations
lv / Latvian
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: ksb, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8435138 [details]
1041 and 1042 tabs.

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140506152807

Steps to reproduce:

Close Firefox.


Actual results:

Warning "You are about to close x tabs. Are you sure you want to continue?" not shown in popup window if x has 4 numbers and less than 2 of them are "1".
i.e.:
x = 1041 - ok
x = 1042 - hidden
.. - hidden
x = 1050 - hidden
x = 1051 - hidden

Probably - other numbers other than 1 are to wide.

Checkbox with text about warning closing multiple tabs always ok.


Expected results:

Always show text with number of tabs.
(Reporter)

Comment 1

3 years ago
Sorry 1051 should be:
x = 1051 - ok
(Reporter)

Comment 2

3 years ago
Additional info - problem also with 3 number if one of them != 1.

Comment 3

3 years ago
Like bug 1018585.

http://transvision.mozfr.org/?recherche=pluralRule&repo=release&sourcelocale=en-US&locale=lv&search_type=entities
http://transvision.mozfr.org/?recherche=tabs.closeWarningMultiple&repo=release&sourcelocale=en-US&locale=lv&search_type=entities
https://developer.mozilla.org/en-US/docs/Mozilla/Localization/Localization_and_Plurals#Plural_rule_.233_.283_forms.29
Status: UNCONFIRMED → NEW
Component: Untriaged → lv / Latvian
Ever confirmed: true
Product: Firefox → Mozilla Localizations
Summary: While closing FF, warning text not shown if number of tabs too long. → While closing FF, warning text may not shown in lv
Version: 29 Branch → unspecified
(Reporter)

Comment 4

3 years ago
Ok in FF30
It is really fixed?
The bug is still open, so it's not fixed.

Raivis, are you following your locale component?
Flags: needinfo?(orvils)

Comment 6

3 years ago
The bug seems to be fixed. 

In FF 29 there were multiple issues with strings that are fixed now.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(orvils)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.