crash in CDevice::ID3D10Device1_CopyResource_(ID3D10Device1*, ID3D10Resource*, ID3D10Resource*)

RESOLVED DUPLICATE of bug 1061696

Status

()

Core
Graphics: Layers
--
critical
RESOLVED DUPLICATE of bug 1061696
4 years ago
4 years ago

People

(Reporter: juanb, Unassigned)

Tracking

(Blocks: 1 bug, {crash})

32 Branch
x86
Windows NT
crash
Points:
---

Firefox Tracking Flags

(firefox31 affected)

Details

(crash signature)

(Reporter)

Description

4 years ago
This bug was filed from the Socorro interface and is 
report bp-21b11ae2-1859-4a0f-a246-c9d1e2140522.
=============================================================

New signature in nighty 32.0a1 starting around 5/21. Almost all of these crashes are happening on Windows 7. There are no comments yet.

More reports at: https://crash-stats.mozilla.com/report/list?product=Firefox&signature=CDevice%3A%3AID3D10Device1_CopyResource_%28ID3D10Device1%2A%2C+ID3D10Resource%2A%2C+ID3D10Resource%2A%29

0 	d3d10_1core.dll 	CDevice::ID3D10Device1_CopyResource_(ID3D10Device1 *,ID3D10Resource *,ID3D10Resource *) 	
1 	d3d10_1core.dll 	NMultithread::CDevice::CopyResource(ID3D10Resource *,ID3D10Resource *) 	
2 	xul.dll 	mozilla::gfx::AutoSaveRestoreClippedOut::Save() 	gfx/2d/DrawTargetD2D.cpp
3 	xul.dll 	mozilla::gfx::DrawTargetD2D::ClearRect(mozilla::gfx::RectTyped<mozilla::gfx::UnknownUnits> const &) 	gfx/2d/DrawTargetD2D.cpp
4 	xul.dll 	mozilla::layers::RotatedBuffer::DrawBufferQuadrant(mozilla::gfx::DrawTarget *,mozilla::layers::RotatedBuffer::XSide,mozilla::layers::RotatedBuffer::YSide,mozilla::layers::RotatedBuffer::ContextSource,float,mozilla::gfx::CompositionOp,mozilla::gfx::SourceSurface *,mozilla::gfx::Matrix const *) 	gfx/layers/RotatedBuffer.cpp
5 	xul.dll 	mozilla::layers::RotatedBuffer::DrawBufferWithRotation(mozilla::gfx::DrawTarget *,mozilla::layers::RotatedBuffer::ContextSource,float,mozilla::gfx::CompositionOp,mozilla::gfx::SourceSurface *,mozilla::gfx::Matrix const *) 	gfx/layers/RotatedBuffer.cpp
6 	xul.dll 	mozilla::layers::ContentClientDoubleBuffered::UpdateDestinationFrom(mozilla::layers::RotatedBuffer const &,nsIntRegion const &) 	gfx/layers/client/ContentClient.cpp
7 	xul.dll 	mozilla::layers::ContentClientDoubleBuffered::FinalizeFrame(nsIntRegion const &) 	gfx/layers/client/ContentClient.cpp
8 	xul.dll 	mozilla::layers::RotatedContentBuffer::BeginPaint(mozilla::layers::ThebesLayer *,unsigned int) 	gfx/layers/RotatedBuffer.cpp
9 	xul.dll 	mozilla::layers::ContentClientRemoteBuffer::BeginPaintBuffer(mozilla::layers::ThebesLayer *,unsigned int) 	obj-firefox/dist/include/mozilla/layers/ContentClient.h
10 	xul.dll 	mozilla::layers::ClientThebesLayer::PaintThebes() 	gfx/layers/client/ClientThebesLayer.cpp
11 	xul.dll 	mozilla::layers::ClientThebesLayer::RenderLayer() 	gfx/layers/client/ClientThebesLayer.cpp
12 	xul.dll 	mozilla::layers::ClientContainerLayer::RenderLayer() 	gfx/layers/client/ClientContainerLayer.h
13 	xul.dll 	mozilla::layers::ClientLayerManager::EndTransactionInternal(void (*)(mozilla::layers::ThebesLayer *,gfxContext *,nsIntRegion const &,mozilla::layers::DrawRegionClip,nsIntRegion const &,void *),void *,mozilla::layers::LayerManager::EndTransactionFlags) 	gfx/layers/client/ClientLayerManager.cpp
14 	xul.dll 	mozilla::layers::ClientLayerManager::EndTransaction(void (*)(mozilla::layers::ThebesLayer *,gfxContext *,nsIntRegion const &,mozilla::layers::DrawRegionClip,nsIntRegion const &,void *),void *,mozilla::layers::LayerManager::EndTransactionFlags) 	gfx/layers/client/ClientLayerManager.cpp
15 	xul.dll 	nsDisplayList::PaintForFrame(nsDisplayListBuilder *,nsRenderingContext *,nsIFrame *,unsigned int) 	layout/base/nsDisplayList.cpp
16 	xul.dll 	nsLayoutUtils::PaintFrame(nsRenderingContext *,nsIFrame *,nsRegion const &,unsigned int,unsigned int) 	layout/base/nsLayoutUtils.cpp
17 	xul.dll 	PresShell::Paint(nsView *,nsRegion const &,unsigned int) 	layout/base/nsPresShell.cpp
18 	xul.dll 	nsViewManager::ProcessPendingUpdatesPaint(nsIWidget *) 	view/src/nsViewManager.cpp
19 	xul.dll 	nsViewManager::ProcessPendingUpdatesForView(nsView *,bool) 	view/src/nsViewManager.cpp
20 	xul.dll 	nsViewManager::ProcessPendingUpdates() 	view/src/nsViewManager.cpp
21 	xul.dll 	nsRefreshDriver::Tick(__int64,mozilla::TimeStamp) 	layout/base/nsRefreshDriver.cpp
22 	xul.dll 	mozilla::RefreshDriverTimer::Tick() 	layout/base/nsRefreshDriver.cpp
23 	xul.dll 	nsTimerImpl::Fire() 	xpcom/threads/nsTimerImpl.cpp
24 	xul.dll 	nsTimerEvent::Run() 	xpcom/threads/nsTimerImpl.cpp
25 	xul.dll 	nsThread::ProcessNextEvent(bool,bool *) 	xpcom/threads/nsThread.cpp
26 	xul.dll 	NS_ProcessNextEvent(nsIThread *,bool) 	xpcom/glue/nsThreadUtils.cpp
27 	xul.dll 	mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate *) 	ipc/glue/MessagePump.cpp
28 	xul.dll 	MessageLoop::RunHandler() 	ipc/chromium/src/base/message_loop.cc
29 	xul.dll 	MessageLoop::Run() 	ipc/chromium/src/base/message_loop.cc
30 	xul.dll 	nsBaseAppShell::Run() 	widget/xpwidgets/nsBaseAppShell.cpp
31 	xul.dll 	nsAppShell::Run() 	widget/windows/nsAppShell.cpp
32 	xul.dll 	nsAppStartup::Run() 	toolkit/components/startup/nsAppStartup.cpp
33 	xul.dll 	XREMain::XRE_mainRun() 	toolkit/xre/nsAppRunner.cpp
34 	xul.dll 	XREMain::XRE_main(int,char * * const,nsXREAppData const *) 	toolkit/xre/nsAppRunner.cpp
35 	xul.dll 	XRE_main 	toolkit/xre/nsAppRunner.cpp
36 	firefox.exe 	do_main 	browser/app/nsBrowserApp.cpp
37 	firefox.exe 	NS_internal_main(int,char * *) 	browser/app/nsBrowserApp.cpp
38 	firefox.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp
39 	firefox.exe 	__tmainCRTStartup 	f:/dd/vctools/crt_bld/self_x86/crt/src/crtexe.c:552
40 	kernel32.dll 	BaseThreadInitThunk 	
41 	ntdll.dll 	__RtlUserThreadStart 	
42 	ntdll.dll 	_RtlUserThreadStart
This is the 12th topcrash signature among sessions attempting D3D11 layers.
Blocks: 1061693
This could be fixed by the patch in bug 1061696. Let's see when it lands.
No crash recorded on any build that was made after the patch in bug 1061696 landed.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1061696
You need to log in before you can comment on or make changes to this bug.