installing packaged app from domain not listed in installs_allowed_from silently fails

RESOLVED INVALID

Status

Firefox Graveyard
Web Apps
RESOLVED INVALID
4 years ago
2 years ago

People

(Reporter: bwalker, Unassigned)

Tracking

30 Branch
x86
Mac OS X

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
STR:

1. Find a Marketplace packaged app whose installs_allowed_from is not "*" (example: https://marketplace.firefox.com/app/line)
2. Create a web page that invokes mozApps.installPackage on that app
3. Host that page on a domain not listed in installs_allowed_from
4. Try to install

Expected results:

The onerror() callback is invoked with some message about origin denied

Actual results:

Install appears to succeed but no app appears in application folder. Neither success nor error callback is ever invoked.
Created attachment 8436173 [details]
Test page

The update manifest doesn't specify installs_allowed_from, so the |onsuccess| callback of |installPackage| is successfully called. Then, when the package is downloaded, the |ondownloaderror| callback of the app object is called with INSTALL_FROM_DENIED.
(This is the expected behavior of the API)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
(Reporter)

Updated

4 years ago
Duplicate of this bug: 1024615
(Assignee)

Updated

2 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.