[camera] [flame] spinner appears after every photo capture

RESOLVED FIXED

Status

Firefox OS
Gaia::Camera
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: tif, Unassigned)

Tracking

unspecified
x86
Mac OS X

Firefox Tracking Flags

(b2g-v2.0 affected)

Details

(Whiteboard: interaction-design)

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
STR - on the Flame:
1. Open Camera app
2. Take a photo

Expected
Spinner shows for significant delays

Actual
Spinner shows for every photo
(Reporter)

Updated

4 years ago
Whiteboard: interaction-design
Created attachment 8435754 [details] [review]
pull-request (master)
Attachment #8435754 - Flags: ui-review?(tshakespeare)
Attachment #8435754 - Flags: review?(jdarcangelo)
Comment on attachment 8435754 [details] [review]
pull-request (master)

Going to R- until you make the changes we discussed. Flag me again when ready, thanks!
Attachment #8435754 - Flags: review?(jdarcangelo) → review-
(Reporter)

Comment 3

4 years ago
Comment on attachment 8435754 [details] [review]
pull-request (master)

Excellent! Spinner shows up for HDR but not after every single photo. Thanks Wilson!
(Reporter)

Comment 4

4 years ago
Comment on attachment 8435754 [details] [review]
pull-request (master)

Actually changing the flag this time! :)
Attachment #8435754 - Flags: ui-review?(tshakespeare) → ui-review+
Wilson: Any progress with this?
Flags: needinfo?(wilsonpage)
Comment on attachment 8435754 [details] [review]
pull-request (master)

Implemented discussed more useful solution. If the busy 'type' is defined in the loadScreen config, we display a loading screen after the given delay. For unrecognised or undefined types, no loading screen is shown.
Attachment #8435754 - Flags: review- → review?(jdarcangelo)
Flags: needinfo?(wilsonpage)
Comment on attachment 8435754 [details] [review]
pull-request (master)

Looks good man! Thanks for making the changes!
Attachment #8435754 - Flags: review?(jdarcangelo) → review+
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Comment 9

4 years ago
This issue also occurs on today's 2.0 Flame.

Environmental Variables:
Device: Flame 2.0
Build ID: 20140701000201
Gaia: 8fb5e2a9ad1025ee7d247b90af7499766afadd28
Gecko: 5da69a493324
Version: 32.0a2 (2.0)
Firmware Version: v122

User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
status-b2g-v2.0: --- → affected
Flags: needinfo?(wilsonpage)
Fixed by bug 1001530
Flags: needinfo?(wilsonpage)
Oops ignore last comment, wrong bug.
[flame][v2.0] Everything seems to work as expected.

- Taking pictures with HDR *off*, shows no spinner. 
- Taking pictures with HDR *on*, shows spinner to account for processing time.
[flame][v2.0] CORRECTION: I am able to reproduce.
Re-opening to address v2.0 uplift.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Created attachment 8449503 [details] [review]
pull-request (v2.0)
Attachment #8449503 - Flags: review?(jdarcangelo)
Comment on attachment 8449503 [details] [review]
pull-request (v2.0)

LGTM!
Attachment #8449503 - Flags: review?(jdarcangelo) → review+
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.