console in workers created from JSMs do not emit output to the browser console

RESOLVED DUPLICATE of bug 1058644

Status

()

defect
RESOLVED DUPLICATE of bug 1058644
5 years ago
5 years ago

People

(Reporter: pellenbogen, Unassigned)

Tracking

29 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140428193813

Steps to reproduce:

I created a worker.js file with a single console.log statement. From a javascript code module I load this file into a web worker. 

An demo extension that tries to log from a worker is attached.


Actual results:

No output from the web worker is produced on the browser console.


Expected results:

I should the log statement from the worker on the browser console, in my case: "Worker says Hello!"
(Reporter)

Updated

5 years ago
Summary: console in workers does not emit output to console debugger → console in workers created from JSMs do not emit output to the browser console
(Reporter)

Comment 1

5 years ago
I don't know if this is the correct thing to do, but I am tagging Andrea Marchesini because they worked on the original implementation: https://bugzilla.mozilla.org/show_bug.cgi?id=620935
Flags: needinfo?(amarchesini)
Workers created from JSM cannot use Console API at the moment because the window object is required.
Bug 988636 is about this.
Flags: needinfo?(amarchesini)
(Reporter)

Updated

5 years ago
Depends on: 988636
bug 1058644 fixes this issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1058644
You need to log in before you can comment on or make changes to this bug.