[B2G][Tarako][Email] User will have to delete Gmail and Outlook accounts and sign them in again for emails to appear

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::E-Mail
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: rpribble, Assigned: asuth)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v1.3T affected)

Details

(Whiteboard: [tarako-exploratory], URL)

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
Created attachment 8435354 [details]
DumpLog.txt

Description:
When the user initially logs in to two accounts at once (tested with a Gmail and an Outlook account), after the second account is signed in no emails will appear in the inbox.  The user will have to delete both accounts and resign in to both of them for emails to sync and appear normally. After the gmail account is signed in, emails will be seen in the inbox.  After the second email is signed in to next, emails will no longer show in the Inbox.

Prereqs: 
1) All steps should be performed from a fresh factory reset

Repro Steps:
1) Update device to BuildID: 20140602014001
2) Connect to wifi
3) Launch email app
4) Sign in to a Gmail account
5) Observe emails appear in Inbox
6) Sign in to an Outlook account
7) Observe inbox no longer show emails
   

Actual:
No emails will show after logging in to he second email account.

Expected:
User does not have to delete and resign in to accounts for them to sync correctly.

Environmental Variables:
Device: Tarako 1.3T
BuildID: 20140602014001
Gaia: 335486c42498fa7a93c21e4d6121199728602ab8
Gecko: 55e4d83019e5
Version: 28.1
Firmware Version: SP6821a-Gonk-4.0-4-29

Repro frequency: 100%
See attached: Dump log

-------------------------------------------

Notes:

-Tarako has stopped signing in to email at all after another factory reset. Will keep trying and attach a video and logcat when possible.

-Qawanted for Buri v1.3 results. Moving to Bug Bash.
I can't reproduce this issue on today's build with the given steps.  Can you please retest?
Maybe there might be some additional steps?  Like placing an app in the background or changing a setting somewhere?

Gaia      33025a8b1e458ef48cb8b7fb81bdaba28c86b183
Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/rev/161d4b0448c6
BuildID   20140606014002
Version   28.1
ro.build.version.incremental=eng.cltbld.20140606.050809
ro.build.date=Fri Jun  6 05:08:16 EDT 2014
Tarako
Flags: needinfo?(rpribble)
(Assignee)

Comment 2

4 years ago
The attached log contained no output from the email.

(In reply to Rachel Pribble from comment #0)
> 6) Sign in to an Outlook account
> 7) Observe inbox no longer show emails

Note that at this point we will be trying to show the emails retrieved from the hotmail/outlook server.  It's expected that nothing will be displayed until sync completes.  It is conceivable that something bad happens during this process or a related bug like bug 825538 (if the credentials are not distinct to the device) is causing weird things to happen.

Since you've additionally indicated that the phone exhibited other weird problems (which could be explained by the server becoming suspicious of the account/IP/etc.), and Naoki indicates it works fine for him, I'm tentatively resolving WFM.

Please feel free to reopen if you are able to reproduce and provide a logcat covering the test period.  Please see https://wiki.mozilla.org/Gaia/Email/RequiredBugInfo for further details on that.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME

Updated

4 years ago
Keywords: qawanted
(Reporter)

Comment 3

4 years ago
Created attachment 8437814 [details]
NewDumpLog.txt

I am still seeing this issue on the current v1.3T build. I'm attaching a logcat following the steps on the listed document, a logcat pulled using Eclipse, and a rather lengthy video of my steps from a factory reset in case there's anything I'm missing.

Prereqs: 
1) All steps should be performed from a fresh factory reset

Repro Steps:
1) Update device to BuildID: 20140609014001
2) Settings > connect to wifi > home button
3) Launch the email app
4) Sign in to a Gmail account > proceed through setup without making any changes
5) Observe emails appear in Inbox
6) Tap drawer icon in upper left > settings icon > add new account
7) Sign in to an Outlook account
8) Proceed through setup without making any changes
9) Observe inbox no longer show emails

v1.3T Environmental Variables:
Device: Tarako v1.3T MOZ ril
BuildID: 20140609014001
Gaia: adb258b88485ccf1ff2e971de0fda547e4bb7149
Gecko: e8b77a1c7c78
Version: 28.1
Firmware Version: SP6821a-Gonk-4.0-5-12
Attachment #8435354 - Attachment is obsolete: true
Flags: needinfo?(rpribble)
(Reporter)

Comment 4

4 years ago
Created attachment 8437816 [details]
EclipseLogcat.txt
Andrew, can you look at her logcat please?
This line concerns me:
06-10 13:24:00.811 I/Gecko   (  498): [32mWLOG: Refreshing fake inbox[0m

I think somehow she went through a different code path than I ran through.
Flags: needinfo?(bugmail)
(Assignee)

Comment 6

4 years ago
The "Refreshing fake inbox" isn't concerning on its own.  At account creation time there's an inherent race between synchronizing the folder list and our first sync of the inbox.  If the first sync is requested before the folder list sync completes, we say "Refreshing fake inbox" and trigger a sync.

The concerning bit is that we then appear to believe we know the server id for the inbox and that we assert that there are 0 messages in there.  The possibilities are somewhat limited.  Either there are no messages in the inbox or we are being told about multiple default inboxes and getting confused.

I am expecting this to be an account-specific problem.

So there are 2 major ways we can go with this:

1) If the credentials are test-only and there's nothing private, send them to asuth@mozilla.com and I can take a look.

2) If it's a personal account, try and reproduce again but this time wait a large number of seconds before continuing to the inbox.  Specifically we want to see these lines go by before advancing beyond the page that asks you whether to enable periodic sync/generate notifications:
  06-10 13:24:00.771 I/Gecko   (  498): WLOG: Added folder Archive (1/1)
  06-10 13:24:00.781 I/Gecko   (  498): WLOG: Added folder Drafts (1/2)
waiting for like 10 seconds or so should also guarantee that folder sync completes if you're not watching logcat as it happens.  I would want the logcat in this case, the NewDumpLog you provided is fine.  No video is required.  I may need to follow this up with an instrumented build, etc.

Thanks
Status: RESOLVED → REOPENED
Flags: needinfo?(rpribble)
Resolution: WORKSFORME → ---
(Reporter)

Comment 7

4 years ago
They are just test accounts. Emailing credentials now.
Flags: needinfo?(rpribble)
I found that I hit a condition that might be the same as this:
1) Sim data was already on
2) I turned wifi on at the same time as logging in and got one hotmail account to show twice on the accounts tab.  

I had to delete one of the hotmail accounts in order for both hotmail and gmail accounts to show correctly.
(Assignee)

Comment 9

4 years ago
:nhirata, do you have a logcat from that?  We used to have a situation like that, but I thought we fixed it fairly comprehensively.  Certainly double-ActiveSync creation is pretty horrible and may run afoul of the same-device-id problem pretty thoroughly.
Flags: needinfo?(bugmail) → needinfo?(nhirata.bugzilla)
(Assignee)

Updated

4 years ago
Assignee: nobody → bugmail
Status: REOPENED → ASSIGNED
Need to check if this happens on 1.3.
Keywords: qawanted

Updated

4 years ago
QA Contact: dgomez
This issue DOES NOT occur on Buri 1.3. The email loads as expected.

1.3 Environmental Variables:
Device: Buri 1.3
Build ID: 20140611130105
Gaia: 7a69ecba7119b7f45fd91f291c1c996326f35978
Gecko: 96725a61c4fb
Version: 28.0 (1.3) 
Firmware Version: v1.2device.cfg


This issue DOES NOT occur on Flame Base v10G-2. The email loads as expected.

1.3 Environmental Variables:
Device: Flame 1.3
BuildID: 20140520094859
Gaia: a73235d23685e9898f40647cebd83b3fcbfd0117
Gecko: Unknown
Version: 28.0
Firmware Version: v10G-2
User Agent: Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
Created attachment 8439522 [details]
multiIP_v2.log

asuth, I couldn't capture the event that I had before where I got 2 accounts showing.  I think it's a timing that I managed to hit unluckily once. 

I did figure out a situation where Loading Messages seems to go on forever.
I setup one email account ( gmail ) via Mobile Sim and shortly after I sent up another account using wifi
Flags: needinfo?(nhirata.bugzilla)
(Assignee)

Comment 13

4 years ago
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #12)
> Created attachment 8439522 [details]
> multiIP_v2.log
> 
> asuth, I couldn't capture the event that I had before where I got 2 accounts
> showing.  I think it's a timing that I managed to hit unluckily once. 

Hm, well, it's still probably a bug, but this suggests it is harder to hit so we won't worry about it too urgently right now... please do file a bug if you hit it again in the future.  (Ideally when testing email please be running with a tee'd logcat already.  On high-memory flame we might be able to address by just cranking the logcat all the way up/etc.)

> I did figure out a situation where Loading Messages seems to go on forever.
> I setup one email account ( gmail ) via Mobile Sim and shortly after I sent
> up another account using wifi

Based on what I'm seeing on the log, it looks like this is a lower level network stack issue that the email app isn't equipped to do too much about.  Specifically, I see:

06-12 14:35:02.507 I/GeckoDump(  465): LOG: Preloading cards: settings_main,account_picker
06-12 14:36:04.477 I/Gecko   (  465): WWAR: Conn steady error: [object Object] on imap.googlemail.com 993
06-12 14:36:05.517 I/Gecko   (  465): WLOG: syncDateRange: 1402272000000 null
06-12 14:36:05.527 I/Gecko   (  465): WLOG: Skewed DB lookup. Start:  1402297200000 Mon, 09 Jun 2014 07:00:00 GMT End:  null null
06-12 14:36:05.537 I/Gecko   (  465): WLOG: searchargs:  NOT DELETED SINCE 9-Jun-2014

This suggests to me that something that happened before the start of the log you provided had established a connection to gmail and that we were waiting on that.  It eventually timed out / got reset, and then we were able to do the right thing.  

We are theoretically able to do a little better than this, so I've filed bug 1024744 for that, but the short story is "it's a platform/OS issue and any improvements email implements are a clever workaround."
Flags: needinfo?(jmitchell)
(Assignee)

Comment 14

4 years ago
Rachel provided me with the credentials privately.  When I just logged into the outlook.com account both via the email app and using the outlook.com web interface, I found there were now only 3 messages in the folder and the oldest was ~3 days ago.  The Inbox having been empty is consistent with all reported symptoms on the bug.  The most likely explanation is confusion relating to the email app's behaviour when adding new accounts (the most recently added inbox is displayed), and perhaps bad autocomplete or something else leading to whatever messages were used to try and populate the Inbox not actually going to that account.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → WORKSFORME

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
You need to log in before you can comment on or make changes to this bug.