[B2G][Vertical Homescreen]Dragging apps to the bottom of the homescreen enables the user to place them anywhere

RESOLVED DUPLICATE of bug 1021554

Status

Firefox OS
Gaia::Homescreen
RESOLVED DUPLICATE of bug 1021554
4 years ago
4 years ago

People

(Reporter: DerekH, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 affected)

Details

(Whiteboard: [2.0-flame-test-run-1][systemsfe], URL)

Attachments

(1 attachment)

Created attachment 8435410 [details]
Flame Logcat 2.0

Description:
When the user drags an app to the bottom of the screen and holds the app until it become more opaque, the app will not come out of edit mode. The user will be able to place the app anywhere on the screen without it snapping to the homescreen

Repro Steps:
1) Update a Flame to BuildID: 20140605040202
2) Open Browser App> Go to a website
3) Tap on the Star and add the website to the homescreen
4) Long press on the icon to go to edit mode and drag to the bottom of the screen
5) Long press on the app again and drag to the bottom of the screen

Actual:
When the user lets go of the app it will stay enlarged and the user is able to place the app icon anywhere without it snapping into a group. All apps are unusable until the phone is restarted

Expected:
The app snaps into a group at the bottom of the homescreen

Flame 2.0

Environmental Variables:
Device: Flame 2.0
Build ID: 20140605040202
Gaia: d2cfef555dabab415085e548ed44c48a99be5c32
Gecko: 51b428be6213
Version: 32.0a1 (2.0) 
Firmware Version: v10G-2

User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0 

Keywords: Drag, Move, Blink, Flash, Transparent, Opaque, Privileged, Hosted, Last

Notes: This also occurs with marketplace apps, as well as Certified apps, but not as frequently as with bookmark apps

Repro frequency: 70%
Link to failed test case:
See attached: Logcat, Video - https://www.youtube.com/watch?v=iqXDbYr2iV0&edit=vd
This issue DOES occur on Buri 2.0

Buri 2.0

Environmental Variables:
Device: Buri 2.0
Build ID: 20140605040202
Gaia: d2cfef555dabab415085e548ed44c48a99be5c32
Gecko: 51b428be6213
Version: 32.0a1 (2.0) MOZ
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0 


This issue DOES occur on Open C 2.0

Open_C 2.0

Environmental Variables:
Device: Open_C 2.0
Build ID: 20140605040202
Gaia: d2cfef555dabab415085e548ed44c48a99be5c32
Gecko: 51b428be6213
Version: 32.0a1 (2.0) 
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
This is bad. This means that the homescreen is unusable until phone restart.
Blocks: 989848
blocking-b2g: --- → 2.0?
Whiteboard: [2.0-flame-test-run-1] → [2.0-flame-test-run-1][systemsfe]

Updated

4 years ago
Blocks: 1015336
No longer blocks: 989848
Summary: [B2G][Vertical Homescreen]Dragging apps to the bottom of the homescreen enables the user to place them anywehre → [B2G][Vertical Homescreen]Dragging apps to the bottom of the homescreen enables the user to place them anywhere

Updated

4 years ago
QA Whiteboard: [VH-FL-blocking+]

Updated

4 years ago
blocking-b2g: 2.0? → 2.0+
Blocks: 1022414
No longer blocks: 1015336
Moving the blocking flag to the blocking bug here to simplify tracking.
blocking-b2g: 2.0+ → ---

Updated

4 years ago
QA Whiteboard: [VH-FL-blocking+] → [VH-FL-blocking-]
blocking-b2g: --- → 2.0+
kgrandon & I already discussed that we're going to block on the blocking bug here, not the dependencies to simplify tracking
blocking-b2g: 2.0+ → ---

Updated

4 years ago
QA Whiteboard: [VH-FL-blocking-] → [VH-FL-blocking-][VH-FC-blocking+]
Looking at the screenshots in bug 1021554, it's pretty clear that these are the same issue. I'm going to make it as a dupe against that one, because that one has screenshots which are helpful. Thanks for filing.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1021554

Updated

4 years ago
No longer blocks: 1022414
You need to log in before you can comment on or make changes to this bug.