with multiple tabs open, View Page Info always shows info for the first tab

VERIFIED FIXED in mozilla0.9.5

Status

SeaMonkey
Page Info
VERIFIED FIXED
16 years ago
12 years ago

People

(Reporter: jjkarppi, Assigned: Doron Rosenberg (IBM))

Tracking

Trunk
mozilla0.9.5
x86
All

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4+) Gecko/20010927
BuildID:    2001092708

Having multiple tabs open, it's impossible to view page info except for the page
in the first tab.

Reproducible: Always
Steps to Reproduce:
1. Hit Ctrl-T to open a new tab
2. Go to some URL (different than what's in the first tab)
3. Select "View page info" 

Actual Results:  Shows info for the page in the first tab

Expected Results:  Should show page info for the tab that is currently selected
(Assignee)

Comment 1

16 years ago
-> tabbed browser
Component: XP Toolkit/Widgets: XUL → Tabbed Browser
OS: Linux → All
QA Contact: jrgm → blakeross
confirmed on build 2001092803 and 2001093008 on Win2k SP2.

Comment 3

16 years ago
Really confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 4

16 years ago
Created attachment 51585 [details] [diff] [review]
does it like we do it for frames
(Assignee)

Comment 5

16 years ago
basically call BrowserPageInfo(this.target.ownerDocument), which we do for frame
info. This also works with non tabbed.


Comment 6

16 years ago
sr=hyatt
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.5
(Assignee)

Comment 7

16 years ago
anyone want to r=?
Assignee: hyatt → doronr
Status: ASSIGNED → NEW
(Assignee)

Comment 8

16 years ago
Created attachment 51881 [details] [diff] [review]
new patch
(Assignee)

Comment 9

16 years ago
only difference is patching navigatorOverlay's pageinfo function:

-    <command id="View:PageInfo"   oncommand="BrowserPageInfo();"/>
+    <command id="View:PageInfo"  
oncommand="BrowserPageInfo(getBrowser().contentDocument);"/>

thanks to fabian for catching that.

Comment 10

16 years ago
sr=hyatt on new patch

Comment 11

16 years ago
Comment on attachment 51881 [details] [diff] [review]
new patch

r=jag
Attachment #51881 - Flags: superreview+
Attachment #51881 - Flags: review+
*** Bug 103117 has been marked as a duplicate of this bug. ***

Comment 13

16 years ago
Comment on attachment 51881 [details] [diff] [review]
new patch

a=asa (on behalf of drivers) for checkin to 0.9.5
Attachment #51881 - Flags: approval+

Comment 14

16 years ago
fixed
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 15

16 years ago
I'm not sure if this is the same bug or should be filed as a separate bug but
clicking on the security lock at bottom right always shows security info for the
first Tab.
Different bug, please.

Comment 17

16 years ago
Ok. Filed bug 103789
QA Contact: blakeross → sairuh
vrfy'd fixed with 2001.11.28.0x-comm bits on linux rh7.2, mac 10.1.1 and winnt.
Status: RESOLVED → VERIFIED

Updated

16 years ago
Component: Tabbed Browser → Page Info
QA Contact: sairuh → pmac
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.