Closed Bug 1021432 Opened 8 years ago Closed 8 years ago

[flatfish][TCP] YouTube not recognizing Flatfish as tablet

Categories

(Firefox OS Graveyard :: Gaia, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1053712

People

(Reporter: feer56, Assigned: yifan)

References

Details

(Whiteboard: [Flatfish][TCP])

Download YouTube from marketplace on Firefox OS 1.4 flatfish tablet. Open app to discover that YouTube is telling you that adobe flash is required. 

Expected: Mobile version displayed and videos are to able to be played.
I noticed the same thing. I think this is a user agent issue as reported in bug 1018822 https://bugzilla.mozilla.org/show_bug.cgi?id=1018822 For instance Facebook app provides the WAP interface instead of mobile smartphone/tablet or Full site. The user agent doesn't seem to be properly recognized by sites and apps. I think these two reports should be combined as they seem related.
Assignee: nobody → yliao
The youtube app from marketplace is a hosted app, so the web page content fetched depends on the user agent string check on the youtube server. 

Why we still see desktop content on flatfish is because the user agent string of it contains 'tablet', not 'mobile', so the site doesn't provide the mobile content. See https://developer.mozilla.org/en-US/docs/Web/HTTP/Gecko_user_agent_string_reference#Firefox_OS . By the way the UA string of iPad 1 with iOS 5 contains 'mobile' so it gets mobile content from the youtube server. This also applies to other websites.

Possible solutions are:
1. Ask youtube to update their UA string check
2. Hack the UA string on tablets for youtube (and probably other websites as well)
3. Just let it display desktop content

I think we could consult web compatibility team and UX team, see their opinions on this.
Flags: needinfo?(jeliu)
See Also: → youtube.com
We should resolve this via bug 1018821.
Yes, that seems the proper way to resolve it. Issued a bug following the instructions.
Status: NEW → RESOLVED
Closed: 8 years ago
Flags: needinfo?(jeliu)
Resolution: --- → DUPLICATE
Duplicate of bug: 1053712
You need to log in before you can comment on or make changes to this bug.