javascript error in contentAreaUtils.js

VERIFIED FIXED in mozilla0.9.8

Status

SeaMonkey
Tabbed Browser
VERIFIED FIXED
16 years ago
10 years ago

People

(Reporter: Henrik Gemal, Assigned: Christopher Aillon (sabbatical, not receiving bugmail))

Tracking

Trunk
mozilla0.9.8

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
Rightclicking on a image and choosing open in a new tab produces:

Error: newWin is not defined
Source File: chrome://communicator/content/contentAreaUtils.js
Line: 93
(Reporter)

Updated

16 years ago
Component: Browser-General → XP Apps
Summary: javascript error in browser.xml → javascript error in contentAreaUtils.js
*** Bug 102414 has been marked as a duplicate of this bug. ***
re-assigning to default owner
Assignee: asa → pchen
QA Contact: doronr → sairuh

Comment 3

16 years ago
ah yes so heres the dup, sorry guys.
(Reporter)

Comment 4

16 years ago
I'm seeing this error everythime I open link in a new tab. Who's on tab browser?
Bleh.  I'll get this.  Simple fix but there's tabs (yuck) in the JS source which
I'll also clean up.

diff -u -w and diff -u on the way.
Assignee: pchen → caillon
Created attachment 53244 [details] [diff] [review]
diff -u -w
Created attachment 53246 [details] [diff] [review]
diff -u (includes tab cleanup)
stephend, would you please review?
Status: NEW → ASSIGNED
Keywords: patch, review
Target Milestone: --- → mozilla0.9.6
Comment on attachment 53246 [details] [diff] [review]
diff -u (includes tab cleanup)

openNewWindowWith(url) has newWin as a local variable, too, so r=stephend@netscape.com.
Attachment #53246 - Flags: review+

Comment 10

16 years ago
Comment on attachment 53246 [details] [diff] [review]
diff -u (includes tab cleanup)

seems reasonable
sr=alecf
Attachment #53246 - Flags: superreview+

Comment 11

16 years ago
*** Bug 108322 has been marked as a duplicate of this bug. ***

Comment 12

16 years ago
Wait, This patch doesn't address the real problem here though.
Why are we creating a newWin variable in the first place? 
We aren't going to use it anyplace since we open a new tab, and we won't be
remembering any size or position which is what the newWin variable did in the
first place. The solution would be to just remove the parts of the "Open In New
Tab" code that are just leftovers from using "Open in New Window" as a template.

Gettting rid of the tabs works, but don't add variables unnecessarily. patch
coming up.

Comment 13

16 years ago
Created attachment 56381 [details] [diff] [review]
diff made with patch maker remove use of newwin and clean up whitespace
0.9.6 is done.  ->0.9.7
Target Milestone: mozilla0.9.6 → mozilla0.9.7
also see this on linux -> all.
OS: Windows 2000 → All
Hardware: PC → All
Component: XP Apps → Tabbed Browser

Comment 16

16 years ago
could someone review this and perhaps check it in once we are out of the freeze?
Whoops, thought this was checked in all the way.  Only whitespace landed.  I'll
get the rest in for 0.9.8
Target Milestone: mozilla0.9.7 → mozilla0.9.8

Comment 18

16 years ago
ummmm which patch is going in? the one with the current reviews is not
necessarialy the best patch. It works, but it declares a useless variable. (OK,
OK, one variable isn't going to kill us, but I thought we were trying to reduce
bloat.)
Comment on attachment 56381 [details] [diff] [review]
diff made with patch maker remove use of newwin and clean up whitespace

r=caillon
Attachment #56381 - Flags: review+

Comment 20

16 years ago
Comment on attachment 56381 [details] [diff] [review]
diff made with patch maker remove use of newwin and clean up whitespace

sr=jag
Attachment #56381 - Flags: superreview+
Checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
no longer get js error when selecting 'open in new tab' for a linked image
context menu. vrfy'd with 2002.01.07.08 comm bits on linux rh7.2.
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.