[Vertical Homescreen] Icon stuck on vertical homescreen if you create too many "pages"

RESOLVED DUPLICATE of bug 1022414

Status

RESOLVED DUPLICATE of bug 1022414
5 years ago
5 years ago

People

(Reporter: wachen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [2.0-FL-bug-bash])

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 8435566 [details]
2014-06-06-09-51-54.png

Build Information

Device: Flame
Gaia      d2cfef555dabab415085e548ed44c48a99be5c32
Gecko     https://hg.mozilla.org/mozilla-central/rev/51b428be6213
BuildID   20140605040202
Version   32.0a1
ro.build.version.incremental=96
ro.build.date=Fri May 23 11:17:40 CST 2014

Description
Try to drag the icons down all the ways and creating more "page" or "horizontal" lines

Steps to Reproduce
1. Launch "Settings" app
2. Go to "Homescreens" subsection
3. Enable "Vertical Homescreen"
4. Drag icons one by one to the bottom of the page
5. Keep doing step4 

Expected Results
new "pages"/"Vertical Homescreens" created 

Actual Results
Sometimes the icon will stucked there, and there is no way to click other icons. You need to go to settings app and switch to normal homescreen

Other Notes
You can try to release it on horizontal lines, it might reproduce faster


Reproduction Frequency: 100% in the long run
(Reporter)

Comment 1

5 years ago
Created attachment 8435568 [details]
2014-06-06-09-47-42.png
User Story: (updated)
Summary: [Homescreen]Icon stuck on vertical homescreen if you create too many "pages" → [Vertical Homescreen] Icon stuck on vertical homescreen if you create too many "pages"
Component: Gaia → Gaia::Homescreen
Blocks: 1015336
QA Whiteboard: [VH-FL-blocking-]
Technically it shouldn't ever be possible for us to get the homescreen stuck in edit mode, which this bug proves that is possible.
blocking-b2g: --- → 2.0?
Blocks: 1022414
No longer blocks: 1015336
I'm going to flag the blocking bug instead of this one to simplify tracking.
blocking-b2g: 2.0? → ---
QA Whiteboard: [VH-FL-blocking-] → [VH-FL-blocking-][VH-FC-blocking+]
Duplicate of this bug: 1021382
The stuck icon issue should've been resolved with the patch from bug 1022414.

I'm going to close as a duplicate as that bug contains the patch. Thanks for filing.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1022414
No longer blocks: 1022414
You need to log in before you can comment on or make changes to this bug.