Settings link for Mozillians still exists in small screens.

VERIFIED FIXED

Status

Mozilla Reps
reps.mozilla.org
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: Rj Ian S. Sevilla, Assigned: Tushar Bhargava [: theterabyte], Mentored)

Tracking

Details

(Whiteboard: [kb=1402857] [good first bug][lang=html])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8435582 [details]
settings.JPG

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140506152807

Steps to reproduce:

Login the reps account going to dashboard I can't see the settings using Laptop and desktop. I also try to view using my mobile I can login to the website and can see the settings button, once I click it, It says page cannot be display that's for mobile phone.


Actual results:

For Laptop and desktop:
- No settings 

For Mobile:
- There is settings but when click it says cannot display the page.


Expected results:

Able to view the settings
Thanks for reporting that.

From what I see in the screenshot I understand that you've logged in as a Mozillian and not as a Rep. For laptops and desktops this is the expected behaviour. The problem is that we haven't removed the link in the mobile view.

I am changing the bug summary to something more descriptive about the bug.
Summary: Settings on my profile is gone → Settings link for Mozillians still exists in small screens.
Group: mozilla-reps
Whiteboard: [good first bug][lang=html][mentor=jgiannelos@mozilla.com]
(Assignee)

Comment 2

4 years ago
Hi, I think I might be better suited for this bug than Bug 994736. Could I be assigned to it?
(Reporter)

Comment 3

4 years ago
@john hi as far as remember thats my rep account. Because that is my personal email. I use this email for bugzilla only. Can you very it again? Thanks.

Regards,
RJ
(Reporter)

Comment 4

4 years ago
I mean verify it again? This email is not recognize in persona. Thanks.

Rj

Comment 5

4 years ago
It may be noteworthy that RJ's Reps Portal Profile is at https://reps.mozilla.org/u/rjiansevilla/
Assignee: nobody → tushar1995
Hi :theterabyte!
I assigned this bug to you. Feel free to ping me for any help.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Whiteboard: [good first bug][lang=html][mentor=jgiannelos@mozilla.com] → [kb=1402857] [good first bug][lang=html][mentor=jgiannelos@mozilla.com]
@Rj

There are 2 accounts: one with @gmail.com email and another one with @mozillaph.org email.
The rep account matching https://reps.mozilla.org/u/rjiansevilla/ is the @mozillaph.org.
(In reply to Rj Ian S. Sevilla from comment #3)
> @john hi as far as remember thats my rep account. Because that is my
> personal email. I use this email for bugzilla only. 

To clarify: On the reps portal you login with your bugzilla email.
(Reporter)

Comment 9

4 years ago
@John thanks for checking. When I try to use @mozillaph.org when I login on reps portal it says "Email not recognized" something error. The 2nd Time I login recently the password appear but when I click the forget password it says it send to email but didn't received anything.
(Reporter)

Comment 10

4 years ago
Hi @Giorgos I use my persona email which I usually do. Because my bugzilla email is not recognize on persona on reps portal even forget password is not working either if i use my bugzilla email.
Mentor: jgiannelos@mozilla.com
Whiteboard: [kb=1402857] [good first bug][lang=html][mentor=jgiannelos@mozilla.com] → [kb=1402857] [good first bug][lang=html]
(Reporter)

Comment 11

3 years ago
Created attachment 8446294 [details]
Forget Password is not working

Also try my bugzilla email again when I click forget password, but I don't received any confirmation email or instruction to reset the account.
Hi Rj,

The reset password functionality in persona is not somehow related to our portal.
The password you requested to reset is for your persona account. Have you checked your spam folder?
Flags: needinfo?(rjian)
(Reporter)

Comment 13

3 years ago
Hi John,

Yup already check the spam folder no email has been received. The first time I login to persona on rep portal it says email is not registered for rjian@mozillaph.org then on second time password is not recognized, but when I try to do a forget password I don't received any email instruction.
Flags: needinfo?(rjian)

Comment 14

3 years ago
Commit pushed to master at https://github.com/mozilla/remo

https://github.com/mozilla/remo/commit/bc3fc549f28d7b30868073b28680323fc52217a4
[fix bug 1021565] Show settings link to non-mozillians only.

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Updated

3 years ago
Version: unspecified → next
(Reporter)

Comment 15

3 years ago
Hi all,

Can someone help reset my password on the rep portal if it really using the @mozillaph.org email. Thanks

Rj
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Updated

3 years ago
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → INVALID
Resolution: INVALID → FIXED
Verified on stage that the settings link does not exist for a Mozillian account.
Status: RESOLVED → VERIFIED
Version: next → 437
You need to log in before you can comment on or make changes to this bug.