[dolphin][Flame][Camera][v1.4] The Camera Interface display abnormal after share pictures to email in landscape mode

VERIFIED FIXED in Firefox OS v1.4

Status

Firefox OS
Gaia::System::Window Mgmt
--
major
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: yong.ren, Assigned: alive)

Tracking

({regression})

unspecified
2.0 S4 (20june)
ARM
Gonk (Firefox OS)
regression
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:1.4+, b2g-v1.3 unaffected, b2g-v1.3T unaffected, b2g-v1.4 verified, b2g-v2.0 verified, b2g-v2.1 verified)

Details

(Whiteboard: [sprd319395][partner-blocker][p=1], URL)

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 8435616 [details]
Camera_display_abnormal.png

DEFECT DESCRIPTION:
  The Camera Interface display abnormal after share pictures to email in landscape mode 

Steps to reproduce:
----------------------------------------------------
 All operations below are done under the landscape mode

1. Enter Camera, take a photograph
2. click the photograph Thumbnail which is on the left side of capture button. 
3. click the share button and choose Email in share interface
4. the confirmation interface will popup when you are not set up email account, choose "cancel"。

Actual result:
---------------------------------------
The Camera Interface display abnormal 


Expected result:
--------------------------------------- 
The Camera interface display normal 


Additional info:
--------------------------------------
Reproduce rate:  5/5
(Reporter)

Updated

4 years ago
Flags: needinfo?(ttsai)
Flags: needinfo?(styang)
Hi Peipei,
Could you double check it on Flame? thanks.
Flags: needinfo?(styang) → needinfo?(pcheng)
(In reply to Steven Yang [:styang] from comment #1)
> Hi Peipei,
> Could you double check it on Flame? thanks.

Yes. I reproduced on Flame v1.4. Here is what I saw:

4. the confirmation interface will popup when you are not set up email account, choose "cancel"。
   --> After clicking "Cancel", the page returns to picture preview, but half of this screen shows wallpaper. And then it returns to Camera quickly.

But if I select Share to Bluetooth, the preview page will show in portrait mode all the time.
Flags: needinfo?(pcheng)
blocking-b2g: --- → 1.4?
status-b2g-v1.4: --- → affected
Summary: [Tarako][dolphin] [Camera] The Camera Interface display abnormal after share pictures to email in landscape mode → [dolphin] [Camera] The Camera Interface display abnormal after share pictures to email in landscape mode
Whiteboard: [sprd319395]
Summary: [dolphin] [Camera] The Camera Interface display abnormal after share pictures to email in landscape mode → [dolphin][Flame][Camera] The Camera Interface display abnormal after share pictures to email in landscape mode
Hema

This seems to block for 1.4 with Dolphin. Please review.
blocking-b2g: 1.4? → 1.4+
Flags: needinfo?(hkoka)

Comment 4

4 years ago
Justin, Can you investigate this one and check if it is a camera issue?
Flags: needinfo?(jdarcangelo)

Updated

4 years ago
Flags: needinfo?(hkoka)
QA Wanted to check 1.3.
Keywords: qawanted
(In reply to Hema Koka [:hema] from comment #4)
> Justin, Can you investigate this one and check if it is a camera issue?

I was able to consistently reproduce on v1.4 but not v2.0. This issue sounds vaguely familiar though but I can't seem to find a bug number for it. Anyhow, this appears to be a Window Mgmt issue.
Flags: needinfo?(jdarcangelo)
(Reporter)

Comment 7

4 years ago
(In reply to Hema Koka [:hema] from comment #4)
> Justin, Can you investigate this one and check if it is a camera issue?

Hi Hema:

Gallery also have the problem.

steps to reproduce:

  under the landscape mode

1. Enter gallery, click a picture
2. click the share button and choose Email in share interface
3. the confirmation interface will popup when you are not set up email account, choose "cancel"。
 
  Now change to the portrait mode

4. click the share button and choose Email in share interface
5. the confirmation interface will popup when you are not set up email account, choose "cancel"。

The gallery will display abnormal right now。
(Reporter)

Comment 8

4 years ago
(In reply to Jason Smith [:jsmith] from comment #5)
> QA Wanted to check 1.3.

Hi Jason:

   v1.3 don't have this issue。

   and the share Activity don't have the landscape mode in v1.3. but in v1.4  it did.

   is it related with the problem?
Whiteboard: [sprd319395] → [sprd319395][partner-blocker]

Comment 9

4 years ago
Hi! Hema,

Could someone help on this case? Thanks

--
Keven
Component: Gaia::System::Window Mgmt → Gaia::Camera
Flags: needinfo?(hkoka)
Changing component to reflect comment 6.

I am also unable to reproduce this with v2.1/master.
Component: Gaia::Camera → Gaia::System::Window Mgmt
Summary: [dolphin][Flame][Camera] The Camera Interface display abnormal after share pictures to email in landscape mode → [dolphin][Flame][Camera][v1.4] The Camera Interface display abnormal after share pictures to email in landscape mode

Comment 11

4 years ago
(In reply to Keven Kuo [:kkuo] from comment #9)
> Hi! Hema,
> 
> Could someone help on this case? Thanks
> 
> --
> Keven

Keven,

This looks like a window management issue though it manifests on camera...mike moved it to the right component -- Tim/Alive probably are the right people to take a look at this. 

Thanks
Hema
Flags: needinfo?(hkoka)

Comment 12

4 years ago
Hi Alive: can you help?
Flags: needinfo?(alive)

Updated

4 years ago
Flags: needinfo?(ttsai)
QA Contact: rkunkel
(In reply to Jason Smith [:jsmith] from comment #5)
> QA Wanted to check 1.3.

This issue does NOT reproduce in the latest Buri 1.3 build

Environmental Variables:
Device: Buri 1.3
BuildID: 20140613024000
Gaia: 8d6bd6c484557c5322bf14798a4273d2a8f4300f
Gecko: d0c6d2ebfe65
Version: 28.0
Firmware Version: V1.2-device.cfg

-

The issue does NOT reproduce on the latest Open_C Base Image:

Environmental Variables:
Device: Open_C
BuildID: 20140505052400
Version: 28.0
Firmware Version: P821A10v1.0.0B06_LOG_DL



- Providing the rest of the branch information - 

This issue does NOT reproduce in the latest Flame 2.0 build:

Environmental Variables:
Device: Flame 2.0
BuildID: 20140613000203
Gaia: a3a5322692578e0a577fb7fa08e32144b2b05ba3
Gecko: 8897bc43f59b
Version: 32.0a2
Firmware Version: V121-G

-

This issue does NOT reproduce on the latest Flame 2.1 build:

Environmental Variables:
Device: Flame 2.1
BuildID: 20140612040203
Gaia: 41db6954a67efc55016744bc8f6591ae9e07a285
Gecko: 9e8e3e903484
Version: 33.0a1
Firmware Version: V121-G

-

The issue DOES reproduce on the latest v1.4 Buri build:

Environmental Variables:
Device: Buri 1.4
BuildID: 20140612000202
Gaia: 7fc73d4cb1bece31f50e8ccf6fb98af3984a9ebf
Gecko: bcd308fbbf38
Version: 30.0
Firmware Version: V1.2-device.cfg

-

This issue DOES reproduce on the latest v1.4 Open_C build:

Environmental Variables:
Device: Open_C 1.4
BuildID: 20140612000202
Gaia: 7fc73d4cb1bece31f50e8ccf6fb98af3984a9ebf
Gecko: bcd308fbbf38
Version: 30.0
Firmware Version: P821A10v1.0.0B06_LOG_DL
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v1.3: --- → unaffected
status-b2g-v2.0: --- → unaffected
status-b2g-v2.1: --- → unaffected
Flags: needinfo?(jmitchell)
Keywords: qawanted → regression, regressionwindow-wanted
Flags: needinfo?(jmitchell)
Assignee: nobody → alive
Flags: needinfo?(alive)
Created attachment 8440617 [details] [review]
patch for 1.4

The root cause is the active app is still email while gallery app calles resize after it opened. And statusbar will check active app of AWM to decide its height (this is bad but we cannot fix it now). I think this is also reproducible on 2.0+ so I am going to write another patch for 2.0
Attachment #8440617 - Flags: review?(timdream)
Created attachment 8440623 [details] [review]
pat
Attachment #8440623 - Flags: review?(timdream)

Updated

4 years ago
QA Contact: rkunkel
2.1 https://github.com/mozilla-b2g/gaia/commit/646efa07944adfe96c28d6075f95be1037eb657c
1.4 https://github.com/mozilla-b2g/gaia/commit/fc74015d26bcbc3e31a45d34cb65777112a35982
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-b2g-v1.4: affected → fixed
Resolution: --- → FIXED
Whiteboard: [sprd319395][partner-blocker] → [sprd319395][partner-blocker][p=1]

Updated

4 years ago
status-b2g-v2.0: unaffected → affected
status-b2g-v2.1: unaffected → fixed
Keywords: regressionwindow-wanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
v2.0: https://github.com/mozilla-b2g/gaia/commit/aa0e805d63d82951c8e040ae7e270e205415e251

Next time, please just do the v2.0 push while you're at it :)
status-b2g-v1.3T: --- → unaffected
status-b2g-v2.0: affected → fixed
Target Milestone: --- → 2.0 S4 (20june)
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #17)
> v2.0:
> https://github.com/mozilla-b2g/gaia/commit/
> aa0e805d63d82951c8e040ae7e270e205415e251
> 
> Next time, please just do the v2.0 push while you're at it :)

I am told that push on my own will make your work tough, am I wrong? Are we supposed to push to 2.0 on our own from now on?
Flags: in-moztrap?(ychung)
New test case needs to be added. There is no existing test case.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Test case has been added to moztrap:

https://moztrap.mozilla.org/manage/case/14351/
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Flags: in-moztrap?(ychung)
Flags: in-moztrap+

Comment 21

4 years ago
Verified the issue is fixed on 2.1, 2.0 and 1.4

After canceling "Share via email" the user is returned to the camera screen, Camera screen displays normally 

Device: Flame 2.1 KK
BuildID: 20141103001220
Gaia: 027a7de0c95320cea0579bfd1a4ceef3e9038f34
Gecko: ffecb2be228b
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
  
Device: Flame 2.0 KK
BuildID: 20141103000201
Gaia: 7b8df9941700c1f6d6d51ff464f0c8ae32008cd2
Gecko: 82a6ed695964
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 32.0 (2.0)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
  
Device: Flame 1.4
BuildID: 20141031003004
Gaia: 9ff9ee9e56ba04aff6900f872535cd8f3aee7904
Gecko: 6f76cb0d1d05
Gonk: 
Version: 30.0 (1.4)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-v1.4: fixed → verified
status-b2g-v2.0: fixed → verified
status-b2g-v2.1: fixed → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.