Element stays highlighted when pressing on it and sliding outside of it

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: echang, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [2.0-FL-bug-bash])

(Reporter)

Description

4 years ago
### Build Information
Device: Flame
Gaia      908f94fda04462001ece86e6b6c15ad8b05f7526
Gecko     https://hg.mozilla.org/mozilla-central/rev/5e8e9d864a4d
BuildID   20140605160202
Version   32.0a1
ro.build.version.incremental=94
ro.build.date=Tue May 20 09:29:20 CST 2014

### Description

### STR
1. E.G. Open Dialer.
2. E.G. Press on 5, not release it and move your finger to 6.
3. System wide, reproducible in any apps.
https://www.youtube.com/watch?v=G6E95RBnUxg
https://www.youtube.com/watch?v=k7CbYv2zJ5M

### Expected Results
Highlight disappear on 5.

### Reproduction Frequency: 
100%
(Reporter)

Comment 1

4 years ago
Not reproducible on v1.4
Let's see what commit(s) is(are) responsible.
User Story: (updated)
Keywords: regression, regressionwindow-wanted
(Reporter)

Comment 3

4 years ago
APZC off makes the issue not reproducible.
Minor regression - so we probably don't need to do a window here.
Keywords: regressionwindow-wanted

Updated

4 years ago
Component: Gaia → Panning and Zooming
Product: Firefox OS → Core
Depends on: 1009684
This may have been fixed due to recent changes. I don't see the issue in the dialer any more (as per comment 0 STR). Can you please re-test and provide updated STR if you still see it?
Flags: needinfo?(echang)
(Reporter)

Comment 6

4 years ago
Hi Gupta, do you know which bug fixes this? The code is landed to Master but not in Aurora, right? It is not reproducible in yesterday's master v2.1. 

Flame v2.1 Okay
Gaia      649245c238a043af32acb109b2613f578323f8e1
Gecko     https://hg.mozilla.org/mozilla-central/rev/5b64c42742cd
BuildID   20140721160209
Version   34.0a1
ro.build.version.incremental=109
ro.build.date=Mon Jun 16 16:51:29 CST 2014
B1TC00011220

(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #5)
> This may have been fixed due to recent changes. I don't see the issue in the
> dialer any more (as per comment 0 STR). Can you please re-test and provide
> updated STR if you still see it?
Flags: needinfo?(echang)
I don't know which bug exactly, but it would be either bug 1009733 or one of its dependencies/blockers. Those patches are not in Aurora - and I would say are too risky to uplift.

I'm going to close this bug as WFM now that it's fixed on master.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.