Closed Bug 102165 Opened 20 years ago Closed 20 years ago

message text all grey after first signature ("--")

Categories

(SeaMonkey :: MailNews: Message Display, defect)

x86
Windows 2000
defect
Not set
trivial

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 54570

People

(Reporter: mozilla.org, Assigned: bugzilla)

References

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.4+)
Gecko/20010927
BuildID:    2001092703

really trivial, but still:

the mail client parses plaintext messages for an eventual signature.
that is apparently the string "--" followed by a newline (though it
doesn't seem to recognize *all* occurrences, but still *some*). from
this line until the end of the message, the text is displayed grey
instead of black.

nevertheless, it's a common practice (not only on mailing lists) to
forward multiple mails in one message, separated by some delimiter.
in this case, everything from the first signature until the end of
the message (including non-signature content) is displayed grey.

since parsing for eventual delimiters is hardly possible, the fix
would be to check for multiple occurrences of "--"/newline (or
whatever criteria are used to determine signatures) and if true
display the whole message in black.

Reproducible: Sometimes
Steps to Reproduce:
1. Search your mailbox for a message with multiple signatures that
   is displayed as desribed above.

Actual Results:  message is displayed using grey text from the first signature on

Expected Results:  whole message should be displayed using black text
Status: UNCONFIRMED → NEW
Ever confirmed: true
Actually, the delimiter is "-- " followed by a newline (note the space).

Do these digests use multipart/digest?
Content-Type: text/plain

(the ones I'm referring to)
*** Bug 102361 has been marked as a duplicate of this bug. ***
reassigning to ducarroz
Assignee: sspitzer → ducarroz

*** This bug has been marked as a duplicate of 54570 ***
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
verified dup.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.