Closed Bug 1021653 Opened 6 years ago Closed 5 years ago

Unprivileged about:newtab: Convert about:newtab to use HTML instead of XUL

Categories

(Firefox :: New Tab Page, defect)

defect
Not set
Points:
13

Tracking

()

RESOLVED DUPLICATE of bug 1167601

People

(Reporter: Gijs, Unassigned)

References

Details

The first step to make the new tab page unprivileged would be to convert it to use HTML instead of XUL. Tricky things here include:

- RTL support. We'll need to include a dir="&locale.dir;" attribute on <body> at a minimum, but then we'll need to do more work as well to make sure that the CSS works well.
- Flexy things - this should be fixable with the new flexbox support we have
- Not breaking tests - we have a lot of tests for the new tab page, and keeping them working might be tricky.
Flags: firefox-backlog+
Blocks: 1021654
No longer blocks: 1021654
Summary: Convert about:newtab to use HTML instead of XUL → Unprivileged about:newtab: Convert about:newtab to use HTML instead of XUL
Blocks: 1021667
Points: --- → 13
Flags: qe-verify?
Whiteboard: p=13
Marking as a dupe of a much more recent bug that Mike's intern Ursula is working on.  I'll move the bugs that this bug blocks over to that one.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1167601
You need to log in before you can comment on or make changes to this bug.