[Flame][v1.4]Improve wait for test_privileged_app_device_picture_prompt.TestPrivilegedAppDevicePicturePrompt

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::UI Tests
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: AndreiH, Assigned: AndreiH)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
Created attachment 8435772 [details]
download (1).png

The test failed in http://selenium.qa.mtv2.mozilla.com:8080/view/B2G%20Flame/job/b2g.flame.mozilla-b2g30_v1_4.ui.non-smoketest/6/HTML_Report/

And from the looks of it, it seems like the tap on "Device storage" option was done when app was still launching, causing the tap to not work

Traceback (most recent call last):
  File "/var/jenkins/workspace/b2g.flame.mozilla-b2g30_v1_4.ui.non-smoketest/.env/local/lib/python2.7/site-packages/marionette_client-0.7.5-py2.7.egg/marionette/marionette_test.py", line 163, in run
    testMethod()
  File "/var/jenkins/workspace/b2g.flame.mozilla-b2g30_v1_4.ui.non-smoketest/tests/python/gaia-ui-tests/gaiatest/tests/functional/system/test_privileged_app_device_picture_prompt.py", line 22, in test_get_pictures_prompt
    deviceStorage.switch_to_frame()
  File "/var/jenkins/workspace/b2g.flame.mozilla-b2g30_v1_4.ui.non-smoketest/tests/python/gaia-ui-tests/gaiatest/apps/ui_tests_privileged/regions/device_storage.py", line 19, in switch_to_frame
    self.wait_for_element_displayed(*self._frame_locator)
  File "/var/jenkins/workspace/b2g.flame.mozilla-b2g30_v1_4.ui.non-smoketest/tests/python/gaia-ui-tests/gaiatest/apps/base.py", line 42, in wait_for_element_displayed
    lambda m: m.find_element(by, locator).is_displayed())
  File "/var/jenkins/workspace/b2g.flame.mozilla-b2g30_v1_4.ui.non-smoketest/.env/local/lib/python2.7/site-packages/marionette_client-0.7.5-py2.7.egg/marionette/wait.py", line 143, in until
    cause=last_exc)
TimeoutException: Traceback (most recent call last):
  File "/var/jenkins/workspace/b2g.flame.mozilla-b2g30_v1_4.ui.non-smoketest/.env/local/lib/python2.7/site-packages/marionette_client-0.7.5-py2.7.egg/marionette/wait.py", line 122, in until
    rv = condition(self.marionette)
  File "/var/jenkins/workspace/b2g.flame.mozilla-b2g30_v1_4.ui.non-smoketest/tests/python/gaia-ui-tests/gaiatest/apps/base.py", line 42, in <lambda>
    lambda m: m.find_element(by, locator).is_displayed())
  File "/var/jenkins/workspace/b2g.flame.mozilla-b2g30_v1_4.ui.non-smoketest/.env/local/lib/python2.7/site-packages/marionette_client-0.7.5-py2.7.egg/marionette/marionette.py", line 1189, in find_element
    response = self._send_message('findElement', 'value', **kwargs)
  File "/var/jenkins/workspace/b2g.flame.mozilla-b2g30_v1_4.ui.non-smoketest/.env/local/lib/python2.7/site-packages/marionette_client-0.7.5-py2.7.egg/marionette/marionette.py", line 613, in _send_message
    self._handle_error(response)
  File "/var/jenkins/workspace/b2g.flame.mozilla-b2g30_v1_4.ui.non-smoketest/.env/local/lib/python2.7/site-packages/marionette_client-0.7.5-py2.7.egg/marionette/marionette.py", line 634, in _handle_error
    raise NoSuchElementException(message=message, status=status, stacktrace=stacktrace)
TimeoutException: Timed out after 30.2807099819 seconds, caused by <class 'marionette.errors.NoSuchElementException'>
(Assignee)

Updated

4 years ago
Assignee: nobody → andrei.hutusoru
(Assignee)

Comment 1

4 years ago
I looked over this test, and ran it locally without a fail.
From my investigation the current wait is good enough and I cannot find something better.
Works with how the app launches.

Although I will keep an eye on this and see if it fails again.
(Assignee)

Comment 2

4 years ago
This did not fail anymore in the last runs.
I am going to close this, and reopen if it reproduces again.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.