FTU import contacts reports an incorrect number of contacts imported

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::First Time Experience
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: Bebe, Assigned: mai)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.0+)

Details

(Whiteboard: [fromAutomation])

User Story

Description:
<Description>

Environment:
<Environment>

Traceback (most recent call last):
<Traceback>


Reproducible manually: YES/NO

STR:
<STR>


Possible cause: 
<Possible cause> optional
(Reporter)

Description

4 years ago
Description:
FTU app says it has imported 14/14 contacts but when I open the contacts app there are only 12

Environment:
Gaia      857129928b6e56a809cee9d5445effb8fa9f1c2c
Gecko     https://hg.mozilla.org/mozilla-central/rev/c8288d0c7a15
BuildID   20140606040202
Version   32.0a1
ro.build.version.incremental=94
ro.build.date=Tue May 20 09:29:20 CST 2014

Traceback (most recent call last):
File "/var/jenkins/workspace/b2g.flame.mozilla-central.ui.smoketest/.env/local/lib/python2.7/site-packages/marionette_client-0.7.7-py2.7.egg/marionette/marionette_test.py", line 163, in run
testMethod()
File "/var/jenkins/workspace/b2g.flame.mozilla-central.ui.smoketest/tests/python/gaia-ui-tests/gaiatest/tests/functional/ftu/test_ftu_skip_tour.py", line 81, in test_ftu_skip_tour
self.assertEqual(self.ftu.count_imported_contacts, len(self.data_layer.all_contacts))
AssertionError: 4 != 3


Reproducible manually: YES

STR:
1. Flash latest master build
2. go through the steps until the import contacts
3. tap import contacts
4. see how many contacts where imported from sim

Expected:
the same number of contacts in the contacts app

Actual:

Opening the contacts app we find a smaller number of contacts than the nr reported in the FTU app
This needs a video & an indication if this is happening on 1.4.
Keywords: qawanted
(Reporter)

Comment 2

4 years ago
We can't see the fail in 1.4 

This is the first time we see this on master

Updated

4 years ago
blocking-b2g: --- → 2.0?
Component: Gaia::Contacts → Gaia::First Time Experience
Keywords: regression

Updated

4 years ago
Keywords: qaurgent, smoketest
Summary: FTU import contacts reports a incorect number of contacts imported → FTU import contacts reports an incorrect number of contacts imported
QA Contact: jmitchell
Florin - 

Several testers have tried to reproduce this issue but have been unsuccessful. I was hoping you could provide some more specific information about the contacts you are importing, such as: do they all have unique names, unique phone numbers, what information fields are filled out on them?

Thanks
Flags: needinfo?(florin.strugariu)
Clearing flags since the above testing indicates this doesn't reproduce.
Keywords: qaurgent, qawanted, regression, smoketest

Updated

4 years ago
blocking-b2g: 2.0? → ---
Dylan, can you seed the SIM card with a contact (from Android, works); Raymond can help/show you how, if you need it.  Thanks!
Flags: needinfo?(dwong)
(In reply to Stephen Donner [:stephend] from comment #5)
Sure I'll get to it when I can, but do you know which device? If it's b2g-9 there's already a few on there.
Flags: needinfo?(dwong) → needinfo?(stephen.donner)
(In reply to Dylan Chun Wong [:dwong] from comment #6)
> (In reply to Stephen Donner [:stephend] from comment #5)
> Sure I'll get to it when I can, but do you know which device? If it's b2g-9
> there's already a few on there.

Yeah, according to Viorela's email, it's (at least) B2G-9.
Flags: needinfo?(stephen.donner)
Viorela, team -- is this still happening?  When Dylan and I looked, it looked like it had started working recently (Dylan said he imported the contacts onto B2G-9's SIM).
Flags: needinfo?(viorela.ioia)
(Reporter)

Comment 9

4 years ago
I can still reproduce this on my Flame with the Orange Romania SIM
The SIM has 2 contacts on it added by me and some other contacts that came with the SIM(added by the carrier)

These contacts are Police, Fire Department, carrier services, etc.
I don't know how to get the exact SIM content. If you have some suggestions I can try to post the results.

https://www.dropbox.com/s/on5ovim910eii9b/Contacts.3gp

As you can see from the video in FTU we get 14/14 contacts and when we open the Contacts app we have 12 contacts


Gaia      f42ebc93554979501d3ac52bcf9e69cb4b310a4f
Gecko     https://hg.mozilla.org/mozilla-central/rev/9dc0ffca10f4
BuildID   20140610040208
Version   33.0a1
ro.build.version.incremental=94
ro.build.date=Tue May 20 09:29:20 CST 2014
Flags: needinfo?(viorela.ioia)
Flags: needinfo?(florin.strugariu)
Ok - Can you reproduce this on 1.4?
Flags: needinfo?(florin.strugariu)
Thanks; at least it's not because of the lack of contacts on B2G-9.
(Reporter)

Comment 12

4 years ago
On 1.4 on the same phone (Flame + orange Romania SIM) I can import 2 contacts.

The 2 contacts that I manually added on the SIM.

The FTU app reports correctly 2/2 contacts imported

Gaia      7fc73d4cb1bece31f50e8ccf6fb98af3984a9ebf
Gecko     https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/bcd308fbbf38
BuildID   20140612000202
Version   30.0
ro.build.version.incremental=94
ro.build.date=Tue May 20 09:29:20 CST 2014
Flags: needinfo?(florin.strugariu)
test_import_contacts_from_sim.py fails with 'There is no SIM contacts on SIM card' error message.
The test was ran on b2g-4, so I suppose there's no contact on that SIM.
Can someone from MV, please, check if we have contacts on b2g-4 and also add some, if needed?
Flags: needinfo?(dylan)
Flags: needinfo?(dylan)
Flags: needinfo?(dwong)
That's not really the same STR though. The testing for 2.0 uses more than 2 contacts. Can we test on 1.4 using the same conditions as 2.0?
Flags: needinfo?(florin.strugariu)
(Reporter)

Comment 15

4 years ago
Yes Jason


On the Orange Ro SIM I added 2 contacts. 
The SIM has on it some other contacts by default these contacts are Police, Fire Department, carrier services, etc.

The 1.4 build can't detect these contacts.
Flags: needinfo?(florin.strugariu)
So are you saying that you can reproduce this bug on 1.4 or not?
Flags: needinfo?(florin.strugariu)
(Reporter)

Comment 17

4 years ago
Jason I can't reproduce the same issue on 1.4 

But on 1.4 we can't see those SIM contacts
Flags: needinfo?(florin.strugariu)
I've added two SIM contacts on b2g-4. I can't comment on the import of the default contacts from SIM.
Flags: needinfo?(dwong)
Francisco - So in this bug, the FTE reports that 14 contacts were imported, but the contacts app only shows 12 contacts imported. We also know this is SIM-specific, since nobody in the US can reproduce this.

Do you know why we're seeing an incorrect amount of contacts as the import amount in the FTE?
Flags: needinfo?(francisco)
Hi Jason,

We landed 2 weeks ago a better messaging from the different importers (not just SIM), that will try to help the user to understand what's happening better.

In the process of importing we merge contacts if they follow certain rules, now we display messages like X imported, Y merged.

But apparently is not the case. Also you are commenting that looks like it's seem specific and taking into account the numbers (police, fire department, and so on), this looks like SDN numbers.

SDN, service dialing numbers (http://www.forensicswiki.org/wiki/SIM_Cards), are those kind and are sim specific.

We landed bug 876632 one week ago, to import the SDN numbers during the import sim phase, so perhaps is that what we are noticing now.

Looking at the current code the SDN contacts should go through the merging process as well.
Flags: needinfo?(francisco)
Sounds like this is a broken new feature bug only present on 2.0 or later.
blocking-b2g: --- → 2.0?
Marking as blocking until indicated that this isn't something user-facing.

Is there a difference if we import in FTU or in the contacts app? We should move it to the contacts component if it isn't FTU specific.
blocking-b2g: 2.0? → 2.0+

Comment 23

4 years ago
Just to note that probably some of the contacts where through the merge process and that can be the reason why you got less contacts in the contacts app. 

After landing bug 1026370 the SIM card import process can notify how many contacts were actually merged. So I would encourage the reporter to test again with the latest master and see what's happening.
Flags: needinfo?(florin.strugariu)

Comment 24

4 years ago
Assigning Marina, in order to have one person that follows this bug closely
Assignee: nobody → mri
(Assignee)

Comment 25

4 years ago
Hi Florin, 
I cannot to reproduce the error. Would you mind make a test for me?
STR.
1. Remove the simcard contacts
2. Adding the contacts to the sim using 2.0
3. Flash the device
4. Import the SIM contacts from FTU

Regards
(Reporter)

Comment 26

4 years ago
I retested it as you suggested and the correct number of contacts are shown now
Flags: needinfo?(florin.strugariu)
(Reporter)

Comment 27

4 years ago
thanks for the fix all I think we can close this
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
Unfortunately, this issue is still reproducible on the latest v2.0, even after Bug 1025940 was fixed and the fix was uplifted to v2.0.
We need to still investigate this. 
I was able to reproduce the issue locally too, by running the automated test.

Link to Jenkins report: http://selenium.qa.mtv2.mozilla.com:8080/view/B2G%20Flame/job/b2g.flame.mozilla-aurora.ui.smoketest/22/HTML_Report/
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Hi Marina, do you have an updates for this bug?  It is blocking 2.0.  Thanks!
(Assignee)

Comment 30

3 years ago
Hi,
I can not reproduce this bug, I was trying to think the possible scenario, but I didn't find it.  (First, I think it was a migration issue, but if I import the sim contacts with previous versions (e.g. 1.4) after flashing with 2.0 the import works perferctly)

NI to Viorela. Please,  could you try to find a clear STR to reproduce this bug? 

Regards
Flags: needinfo?(viorela.ioia)
Marina, I was able to reproduce the bug by following the STR from the description, but with step 1:
'Flash latest v2.0 build' instead of 'Flash latest master build'. Also, my SIM has SDN (service dialing numbers)
I must mention that I tried to reproduce this failure again, in today's build(see build info below), but with no success.
So I believe the issue was fixed. 
I will close it, as I currently can't reproduce this anymore. I will reopen it if needed.
Thanks!

Device: Flame
Gaia      c0c8ad187c0466285f2580531e09f8322996f561
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/d4dc609bcc8a
BuildID   20140630000201
Version   32.0a2
ro.build.version.incremental=108
ro.build.date=Tue Jun 10 19:40:40 CST 2014
Flags: needinfo?(viorela.ioia)
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.