sending more than one piece of mail fails when posting to sent mail folder

VERIFIED FIXED

Status

--
major
VERIFIED FIXED
18 years ago
11 years ago

People

(Reporter: blizzard, Assigned: naving)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
See bug #101828 for a similar problem.

To reproduce all I have to do is:

1. Open up four new message windows
2. Set To: and From: to the same addresses.
3. Send all four as close to the same time as possible.

I get errors saving mail to the Sent mail folders on the imap servers.

I suspect that these postings need to be serialized as well, just like in bug
101828.
(Assignee)

Comment 1

18 years ago
I suspected this and it shows that this is due to timing issue - copies are
colliding. There will be 4 threads and each of them try to
access the sent folder which some of them find to be locked. I don't know 
if you can solve this problem until you block the send for subsequent messages.

Comment 2

18 years ago
right, and I think that's what the msg copy service does.
(Assignee)

Comment 3

18 years ago
ok, you are right, copyService will hold all the copyRequests and play the copy
one by one in a queue.  That means all these places in mailnews code that do 
not use CopyService are wrong. Right now, copyService is not working as  
expected. An example where it doesn't work, hit delete, delete
to delete 2 local mails very fast and it will assert folder locked for second
message. 
(Assignee)

Comment 4

18 years ago
I will take this bug and log a new bug about using copyService to issue copy
rather than going direclty. This will be lots of changes.
Assignee: ducarroz → naving
(Reporter)

Comment 5

18 years ago
Yeah, there are lots of scary subtle changes.  I've already got a ton of changes
that include some refcnt cycle issues and making the use of
OnStopCopy/OnStartCopy more consistent.
(Assignee)

Comment 6

18 years ago
blizzard, I guess you are working on compose part ? bug 102266 will cover all
of mailnews. you can reassign this to yourself, looks like you may be closer 
to the fix.
(Reporter)

Updated

18 years ago
Depends on: 102266

Comment 7

17 years ago
Blizzard,
Is this bug fixed? Looks like navin wanted this to be assigned to you. I am not 
able to reproduce this problem on linux 2001-12-14-06.  This probably got fixed 
with bug 101828
(Reporter)

Comment 8

17 years ago
Fixing bug 101828 would not have fixed this problem and I can still reproduce
this problem 100% of the time.  It's not fixed.

Comment 9

17 years ago
Hi, I'm still finding a bug like this in build #2002042403 on Win98. I was
creating emails for 6 auctions won on eBay and tried to send them from my POP3
account one after the other. Only the first copy registered in my Sent folder.
Finding this bug I tried to send /another/ email to one person (of the initial
6) asking if they'd received the email and it didn't show up in the Sent folder
either.
Can someone please clarify if the emails are still actually being sent?

Comment 10

17 years ago
In my experience the mails are indeed being sent.

We've been seeing this for months on Solaris/SPARC so I'm changing Platform/OS
to all.

It's causing our users to refuse to use mozilla: with our overloaded SMTP server
it often takes many seconds (up to a minute or so) to deliver a msg and this bug
is forcing users to wait until the mail has fully gone before sending the next
one. If moz blocked in the background that would be fine.

Severity: normal → major
OS: Linux → All
Hardware: PC → All
(Reporter)

Comment 11

17 years ago
This bug isn't about sending mail to the SMTP server - it's about saving your
sent messages to an IMAP folder on an IMAP server.

Comment 12

17 years ago
Which happens when I send mail via SMTP; the copies are going to my Sent folder
via IMAP.

Since the SMTP delivery (which occurs before the copy) takes so long, when
sending multiple emails it's quite easy to get several queued up for SMTP
delivery. The SMTP requests then all tend to go through at once and thus the
IMAP copies to the Sent folder all tend to try and go at once.

[The SMTP delays are a problem at my end - nothing to do with mozilla; they just
make this problem much more of an irritation, since the delays make this bug
occur all the time]

Comment 13

17 years ago
changing QA contact from Sheela to Gregg
QA Contact: sheelar → meehansqa
(Assignee)

Comment 14

17 years ago
This problem is fixed now. The fix is in bug 89285.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 15

17 years ago
Tested using build 2002-08-20-08-1.0. Is working correctly now, no collision of
multiple messages trying to access the same folder at virtually the same time.
Marking as VERIFIED.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.