Wrong font kind when I receive replies from some persons

RESOLVED INVALID

Status

RESOLVED INVALID
4 years ago
2 years ago

People

(Reporter: marcoagpinto, Unassigned)

Tracking

({fonts})

24 Branch
x86_64
Windows 8.1
fonts

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 8435879 [details]
thunderbird2450_20140606.png

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140506152807

Steps to reproduce:

1) I write a simple e-mail and the font is "Variable Width" and it looks like plain text, with my image signature at the bottom.
2) I press SEND


Actual results:

When some persons reply to me, my part of the text seems Times New Roman or whatever (all characters are glued together).

A teacher from the university I work to, complained that I was using a "bad" font for him.


Expected results:

The font in the reply, in my part of the text, should look the same as when I wrote the e-mail.
(Reporter)

Comment 1

4 years ago
Please see the two red rectangles in the screenshot.

The one on top shows the text that the person wrote to me, that looks like the one when I was writing.

On the bottom is my text, it looks "Times New Roman" or whatever.
(Reporter)

Updated

4 years ago
Keywords: fonts
(Reporter)

Comment 2

4 years ago
Created attachment 8435897 [details]
Fonts and Encoding settings, like someone on IRC asked for

Someone on IRC asked for this information

Comment 3

4 years ago
Can you attach the source of the message sent out and then the received message? Export it as .eml and you can remove private lines, just keep headers about the signature specifying the font.

Also attach screenshot of Options -> Composition -> General .
(Reporter)

Comment 6

4 years ago
Created attachment 8436078 [details]
screenshot of Options -> Composition -> General
(Reporter)

Updated

4 years ago
Group: core-security

Updated

4 years ago
Group: core-security

Comment 7

4 years ago
So in the sent message, there is no font specified (even in the HTML version). So it should be fine and displayed according to your preferences in YOUR TB. The recipient also displays it in his own default font.

So if the recipient does not like his own default font, he should not blame you.

In the returned message, there is a ton of junk html added by "Microsoft Word 15", so probably generated by Outlook. There is a ton of font declarations. So if the "bad" font (yes something serif like Times New Roman as displayed in TB) is stored in that code, it was added by the sender. His fault again.

I do not see a problem of Thunderbird here.

Comment 8

2 years ago
closing invalid based on comment 7.
If you disagree with conclusion,  please add new comment
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.