Closed Bug 1021788 Opened 6 years ago Closed 6 years ago

[Messages] Can't click on the suggestion list when there are a lot of recipients in the recipients panel

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

x86_64
Linux
defect
Not set

Tracking

(blocking-b2g:2.0+, b2g-v1.4 unaffected, b2g-v2.0 verified, b2g-v2.1 verified)

VERIFIED FIXED
2.0 S4 (20june)
blocking-b2g 2.0+
Tracking Status
b2g-v1.4 --- unaffected
b2g-v2.0 --- verified
b2g-v2.1 --- verified

People

(Reporter: julienw, Assigned: steveck)

References

Details

(Keywords: regression)

Attachments

(2 files)

STR:
* add a lot of recipients in the recipients panel (at least about 4 lines)
* type something that matches a remaining contact
* try to click the first one

Expected:
* you can click it and it's added in the recipients panel

Actual:
* nothing happens when you click it

This is most certainly a regression of bug 963018.
I remember that we had this issue when we did the first implementation of the panel.

So there are some guesses:
* the "transform" CSS has a bug where we can't touch what would be behind if there was no transformation
* zIndex issue
Assignee: nobody → schung
blocking-b2g: 2.0? → 2.0+
Attached file Link to github
Hi Julien, it's another small fix for subheader, and I think it could also fix the problem in bug 1015867.
Attachment #8438998 - Flags: review?(felash)
Blocks: 1015867
Comment on attachment 8438998 [details] [review]
Link to github

r=me with using "#messages-to-field { height:0 }" instead. (and in composer.css, not in sms.css :) ).
Attachment #8438998 - Flags: review?(felash) → review+
(In reply to Julien Wajsberg [:julienw] from comment #2)
> Comment on attachment 8438998 [details] [review]
> Link to github
> 
> r=me with using "#messages-to-field { height:0 }" instead. (and in
> composer.css, not in sms.css :) ).

Sorry, not in composer.css, it's not part of the composer. In sms.css it's fine.
Some comment in https://github.com/mozilla-b2g/gaia/pull/20417#discussion_r13790731, which I thought is fine for merging because I don't want this awkward befhavior affect our developing. But I could create a bug if you have any suggestion about the recipient list :) 

In master: 892773d763c5d000f616d2158275c61ab1d8c05f
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.0 S4 (20june)
Attached video Verify_Video_Flame.MP4
This issue has been verified successfully on Flame 2.0 &2.1.
See attachment: Verify_Video_Flame.MP4
Reproducing rate: 0/10

Flame v2.0 version:
Gaia-Rev        8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/c756bd8bf3c3
Build-ID        20141202000201
Version         32.0

Flame v2.1 version:
Gaia-Rev        ccb49abe412c978a4045f0c75abff534372716c4
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/18fb67530b22
Build-ID        20141202001201
Version         34.0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.