Closed Bug 1021797 Opened 5 years ago Closed 5 years ago

Rename ArenaFalseCleaner to PORT_FreeArena_false

Categories

(Core :: Security: PSM, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla32

People

(Reporter: cviecco, Assigned: cviecco)

Details

Attachments

(1 file)

Missunderstood a review comment, so we need to rename a function to maintain coding style. See https://bugzilla.mozilla.org/show_bug.cgi?id=1000548#c9.
Assignee: nobody → cviecco
Comment on attachment 8435982 [details] [diff] [review]
rename-plaerna-fix

Review of attachment 8435982 [details] [diff] [review]:
-----------------------------------------------------------------

::: security/pkix/include/pkix/pkixtypes.h
@@ +39,1 @@
>    // PL_FreeArenaPool can't be used because it doesn't actually free the

PORT_FreeArena_false is kind of bad the you would expect PORT_functions to be NSPR functions. Maybe instead: mzPkix_FreeArena_false ?
Attachment #8435982 - Flags: review?(dkeeler)
Comment on attachment 8435982 [details] [diff] [review]
rename-plaerna-fix

Review of attachment 8435982 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for making this change.

::: security/pkix/include/pkix/pkixtypes.h
@@ +39,1 @@
>    // PL_FreeArenaPool can't be used because it doesn't actually free the

I agree it's not the best naming convention. Let's go with PORT_FreeArena_false to be consistent for now. We can change this and the ones in mozilla::psm if we come up with something better later.
Attachment #8435982 - Flags: review?(dkeeler) → review+
https://hg.mozilla.org/mozilla-central/rev/33e00e8b000e
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla32
You need to log in before you can comment on or make changes to this bug.