Closed Bug 1021844 Opened 6 years ago Closed 6 years ago

[Messages] Can't load the application in Firefox

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

x86_64
Linux
defect
Not set

Tracking

(b2g-v2.0 verified, b2g-v2.1 verified)

VERIFIED FIXED
2.0 S4 (20june)
Tracking Status
b2g-v2.0 --- verified
b2g-v2.1 --- verified

People

(Reporter: julienw, Assigned: julienw)

References

Details

(Keywords: regression)

Attachments

(2 files)

This was broken by Bug 1007591.
Attached file github PR
Here is a quick fix so that we can continue to work :)
Attachment #8435940 - Flags: review?(schung)
Comment on attachment 8435940 [details] [review]
github PR

r=me, thanks!
Attachment #8435940 - Flags: review?(schung) → review+
master: 8d865839d932bfbd5e157f376f74d8cb12bfdd51
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Comment on attachment 8435940 [details] [review]
github PR

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 1007591
[User impact] if declined: we can't load the SMS app in Firefox which makes it difficult to debug stuff
[Testing completed]: yes
[Risk to taking this patch] (and alternatives if risky): none
[String changes made]: none

The code path should never happen on a device because mozSetMessageHandler is always present on the device.
Attachment #8435940 - Flags: approval-gaia-v2.0?(bbajaj)
Attachment #8435940 - Flags: approval-gaia-v2.0?(bbajaj) → approval-gaia-v2.0+
Attached video Verify_Video_Flame.MP4
This issue has been verified successfully on Flame 2.0 & 2.1.
See attachment: Verify_Video_Flame.MP4
Reproducing rate: 0/10

Flame v2.0 version:
Gaia-Rev        8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/c756bd8bf3c3
Build-ID        20141202000201
Version         32.0

Flame v2.1 version:
Gaia-Rev        ccb49abe412c978a4045f0c75abff534372716c4
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/18fb67530b22
Build-ID        20141202001201
Version         34.0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.