Delete unwrapBkey from FxA user data after we fetch and calculate keys

RESOLVED FIXED in Firefox 33

Status

()

RESOLVED FIXED
4 years ago
11 months ago

People

(Reporter: ckarlof, Assigned: warner)

Tracking

Trunk
Firefox 33
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

4 years ago
I believe this amounts to adding "delete data.unwrapBKey" here:

http://hg.mozilla.org/mozilla-central/annotate/7146e89a7b83/services/fxaccounts/FxAccounts.jsm#l651

and adding some tests to make sure it gets deleted after a successful key fetch.
(Assignee)

Comment 1

4 years ago
Created attachment 8437097 [details] [diff] [review]
delete unwrapBKey after use, plus tests

This should be everything.
(Assignee)

Updated

4 years ago
Attachment #8437097 - Flags: review?(ckarlof)
(Assignee)

Comment 2

4 years ago
Created attachment 8437111 [details] [diff] [review]
0001-Bug-1021950-delete-unwrapBKey.patch

Ah, this format of patch should be slightly easier to mark checkin-needed.
Attachment #8437097 - Attachment is obsolete: true
Attachment #8437097 - Flags: review?(ckarlof)
Attachment #8437111 - Flags: review?(ckarlof)
(Reporter)

Updated

4 years ago
Attachment #8437111 - Flags: review?(ckarlof) → review+
(Assignee)

Comment 3

4 years ago
There are two unrelated tests which fail when I run the full suite, but those same tests fail when I run an unmodified git checkout (1f1507a8dac30b1bbf934a801d48a684cf375ae0). So I think this is ready for checkin.
Whiteboard: checkin-needed
Please provide a Try link when requesting checkin. If you need some recommendations on what to run, you can take a look at the below:
https://wiki.mozilla.org/Sheriffing/How:To:Recommended_Try_Practices
Whiteboard: checkin-needed
(Assignee)

Comment 6

4 years ago
Thanks Nick!

Ryan: is that sufficient? (sorry, I'm new at using checkin-needed).
Whiteboard: checkin-needed
https://hg.mozilla.org/integration/fx-team/rev/db50d648115a
Flags: in-testsuite+
Whiteboard: checkin-needed → [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/db50d648115a
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → mozilla33
Duplicate of this bug: 1026299

Updated

11 months ago
Product: Core → Firefox
Target Milestone: mozilla33 → Firefox 33
You need to log in before you can comment on or make changes to this bug.