[B2G][Tarako][Email]Sync button animation displays as highlighted rotating rectangle when double tapped

RESOLVED WORKSFORME

Status

defect
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: mclemmons, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v1.3 unaffected, b2g-v1.3T affected, b2g-v1.4 unaffected)

Details

(Whiteboard: [tarako-exploratory], )

Attachments

(2 attachments)

Posted file Firewatch Log
User sets up an email account and accesses the Inbox. When user double taps the sync button in the lower left, the arrow rotates but there is animation around the rotation of a highlighted rotating blue rectangle, sometimes appearing in the white space of the Inbox.  

Prerequisites:
1. Setup email account on device without manual setup 

Repro Steps: 
1) Update a Tarako to BuildID: 20140606014002
2) Tap Email App
3) Double tap sync button and observe device behavior 

Actual: 
The arrow rotates but there is animation around the rotation of a highlighted rotating blue rectangle.

Expected: 
Arrow rotates but there is no animation of a rotating rectangle 

Notes: 
Repro frequency: (23/25, 92%) 

See attached: video = https://www.youtube.com/watch?v=OdFMetkEnxI, logcat, firewatch

The type of device in use
Tarako

The "Build Identifier" of the build you are using
20140606014002 

Confirm the net connection is working
Confirmed

The e-mail domain you used/are using to create the account
hotmail.com and gmail.com 

If this is not a problem creating the account, the account type the e-mail client thinks it is using
hotmail.com – activesync 
gmail.com - imap+smtp

Environmental Variables:
Device: Tarako 1.3T
Build ID: 20140606014002
Gaia: 33025a8b1e458ef48cb8b7fb81bdaba28c86b183
Gecko: 161d4b0448c6
Version: 28.1 (1.3T) 
Firmware Version: SP6821a-Gonk-4.0-5-12
User Agent: Mozilla/5.0 (Mobile; rv:28.1) Gecko/28.1 Firefox/28.1
This issue does not reproduce on Buri 1.3 following STR from Comment 0. Arrow rotates but there is no animation of a rotating rectangle every test attempt. 

Environmental Variables:
Device: Buri 1.3
Build ID: 20140605024002
Gaia: 2408c2238254776b0d3716753b7bf917883c9915
Gecko: 6214d9d288e3
Version: 28.0 (1.3) MOZ
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0
This issues does not reproduce on Flame 1.4 following STR from Comment 0. Arrow rotates but there is no animation of a rotating rectangle every test attempt. 

Flame 1.4
Build ID: 20140606000204
Gecko: https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/960c48b5a5fa
Gaia: 183efb374be1bcbf92f1fb3d0212a68b564a6d3e
Platform Version: 30.0
Firmware Version: V10g-2
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
This is not a blocker candidate for v1.3T and does not exist on trunk, resolving WFM.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.