Error message when sending email with no internet connection should be more user friendly

RESOLVED DUPLICATE of bug 973406

Status

Firefox OS
Gaia::E-Mail
RESOLVED DUPLICATE of bug 973406
3 years ago
3 years ago

People

(Reporter: vt, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8436108 [details]
2014-06-06-14-32-03.png

# Build Information

Device: Flame
Gaia      d2cfef555dabab415085e548ed44c48a99be5c32
Gecko     https://hg.mozilla.org/mozilla-central/rev/51b428be6213
BuildID   20140605040202
Version   32.0a1
ro.build.version.incremental=94
ro.build.date=Tue May 20 09:29:20 CST 2014

# Steps to Reproduce

1) Turn off internet connection (e.g. Airplane mode)
2) Launch email app
3) Press new email button on top right
4) Compose an email
5) Press send

# Expected Results

An error message appears telling you there is no internet connectivity.

# Actual Results

A non-useful error message appears. It says the email failed to send but does not give any indication why. See attached screenshot.
Note: will be obsoleted by background sending.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 973406
You need to log in before you can comment on or make changes to this bug.