Unable to decrease cell height or width if a size has been set in another cell that efffects the cell you are working on

VERIFIED INVALID

Status

VERIFIED INVALID
17 years ago
14 years ago

People

(Reporter: TucsonTester2, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.4)
Gecko/20010924 Netscape6/6.2
BuildID:    20010924

If you set a cell's width to x pixels in the table properties, all cells in that
column have a width of x pixels.  If you are working on another cell in that
column and attempt to change that cell's width, you can set it to greater width
without any problem.  But if you try setting it to a lesser width, it does not
change the width.  The same is true for changing height of a cell and then
trying to change height in a different cell in the same row.

Reproducible: Always
Steps to Reproduce:
1.Open a blank page in composer
2.Click on Table, create a default table
3.Double click on the first cell
4.Set cell height to 100 pixels and cell width to 100 pixels
5.Double click on the cell below the one you altered
6.Set cell width to 50 pixels, observe results
7.Double click on the cell next to the one you altered
8.Set cell height to 50 pixels, observe results

Actual Results:  No change, all cells in the first column still have a width of
100 pixels.  All cells in the first row still have a height of 100 pixels

Expected Results:  The first column should have a width of 50 pixels.  The first
row should have a height of 50 pixels.

This problem can be avoided by selecting column instead of cell to change width,
or row instead of column to change height, but you should not have to do this. 
If I tell it to set the cell's width to a different width, I would expect it to
do so, regardless of what I had told it previously, or else I would expect an
error message telling me why I couldn't do it.  Also, could be rather confusing
to a novice user, since size can increases but not decrease.

Comment 1

17 years ago
Confirmed WIn 2k using build 20011010, WIn 98 using build 20011009, and Mac OSX
using build 20011009.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
I think for obvious reasons the cells have to be as high as the maximally sized
cell in a row.

I scanned the w3 HTML 4.01 Table spec and saw no explicit addressing of this
issue but I would be suprised if tables would be rendered in any other way.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 3

17 years ago
marking VERIFIED-FIXED. Reopen if you can reproduce the bug or you think
its still valid.
Status: RESOLVED → VERIFIED

Comment 4

16 years ago
reassign bugs in case they are later reopened
Assignee: syd → composer
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.