Closed Bug 1022078 Opened 6 years ago Closed 6 years ago

Dolphin builds broken by a recent commit

Categories

(Firefox OS Graveyard :: General, defect, major)

ARM
Gonk (Firefox OS)
defect
Not set
major

Tracking

(b2g-v1.4 fixed, b2g-v2.0 unaffected, b2g-v2.1 unaffected)

RESOLVED FIXED
2.0 S4 (20june)
Tracking Status
b2g-v1.4 --- fixed
b2g-v2.0 --- unaffected
b2g-v2.1 --- unaffected

People

(Reporter: RyanVM, Assigned: RyanVM)

Details

Presumably something in an outside repo changed, because it appears to have recently broken even though I don't see any changes on our end.

https://tbpl.mozilla.org/php/getParsedLog.php?id=41261262&tree=Mozilla-B2g30-v1.4

19:30:42     INFO -  /builds/slave/b2g_m-b30_14_dolphin_eng_dep-0/build/prebuilts/gcc/linux-x86/arm/arm-linux-androideabi-4.7/bin/../lib/gcc/arm-linux-androideabi/4.7/../../../../arm-linux-androideabi/bin/as: /lib64/libz.so.1: no version information available (required by /builds/slave/b2g_m-b30_14_dolphin_eng_dep-0/build/prebuilts/gcc/linux-x86/arm/arm-linux-androideabi-4.7/bin/../lib/gcc/arm-linux-androideabi/4.7/../../../../arm-linux-androideabi/bin/as)
19:30:42     INFO -  target thumb C++: libbinder <= frameworks/native/libs/binder/MemoryHeapBase.cpp
19:30:42     INFO -  target thumb C++: libbinder <= frameworks/native/libs/binder/MemoryHeapIon.cpp
19:30:42     INFO -  /builds/slave/b2g_m-b30_14_dolphin_eng_dep-0/build/prebuilts/gcc/linux-x86/arm/arm-linux-androideabi-4.7/bin/../lib/gcc/arm-linux-androideabi/4.7/../../../../arm-linux-androideabi/bin/as: /lib64/libz.so.1: no version information available (required by /builds/slave/b2g_m-b30_14_dolphin_eng_dep-0/build/prebuilts/gcc/linux-x86/arm/arm-linux-androideabi-4.7/bin/../lib/gcc/arm-linux-androideabi/4.7/../../../../arm-linux-androideabi/bin/as)
19:30:42     INFO -  /builds/slave/b2g_m-b30_14_dolphin_eng_dep-0/build/prebuilts/gcc/linux-x86/arm/arm-linux-androideabi-4.7/bin/../lib/gcc/arm-linux-androideabi/4.7/../../../../arm-linux-androideabi/bin/as: /lib64/libz.so.1: no version information available (required by /builds/slave/b2g_m-b30_14_dolphin_eng_dep-0/build/prebuilts/gcc/linux-x86/arm/arm-linux-androideabi-4.7/bin/../lib/gcc/arm-linux-androideabi/4.7/../../../../arm-linux-androideabi/bin/as)
19:30:42     INFO -  target thumb C++: libbinder <= frameworks/native/libs/binder/Parcel.cpp
19:30:42     INFO -  frameworks/native/libs/binder/MemoryHeapIon.cpp:55:35: fatal error: usr/include/linux/ion.h: No such file or directory
19:30:42     INFO -  compilation terminated.
19:30:42     INFO -  make: *** [out/target/product/scx15_sp7715ga/obj/SHARED_LIBRARIES/libbinder_intermediates/MemoryHeapIon.o] Error 1

I've closed b2g30 until this gets unbroken. Or I can reopen and hide the Dolphin builds. What do we prefer?
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #0)
> Presumably something in an outside repo changed, because it appears to have
> recently broken even though I don't see any changes on our end.
> 
> https://tbpl.mozilla.org/php/getParsedLog.php?id=41261262&tree=Mozilla-B2g30-
> v1.4
> 
> 19:30:42     INFO - 
> /builds/slave/b2g_m-b30_14_dolphin_eng_dep-0/build/prebuilts/gcc/linux-x86/
> arm/arm-linux-androideabi-4.7/bin/../lib/gcc/arm-linux-androideabi/4.7/../../
> ../../arm-linux-androideabi/bin/as: /lib64/libz.so.1: no version information
> available (required by
> /builds/slave/b2g_m-b30_14_dolphin_eng_dep-0/build/prebuilts/gcc/linux-x86/
> arm/arm-linux-androideabi-4.7/bin/../lib/gcc/arm-linux-androideabi/4.7/../../
> ../../arm-linux-androideabi/bin/as)
> 19:30:42     INFO -  target thumb C++: libbinder <=
> frameworks/native/libs/binder/MemoryHeapBase.cpp
> 19:30:42     INFO -  target thumb C++: libbinder <=
> frameworks/native/libs/binder/MemoryHeapIon.cpp
> 19:30:42     INFO - 
> /builds/slave/b2g_m-b30_14_dolphin_eng_dep-0/build/prebuilts/gcc/linux-x86/
> arm/arm-linux-androideabi-4.7/bin/../lib/gcc/arm-linux-androideabi/4.7/../../
> ../../arm-linux-androideabi/bin/as: /lib64/libz.so.1: no version information
> available (required by
> /builds/slave/b2g_m-b30_14_dolphin_eng_dep-0/build/prebuilts/gcc/linux-x86/
> arm/arm-linux-androideabi-4.7/bin/../lib/gcc/arm-linux-androideabi/4.7/../../
> ../../arm-linux-androideabi/bin/as)
> 19:30:42     INFO - 
> /builds/slave/b2g_m-b30_14_dolphin_eng_dep-0/build/prebuilts/gcc/linux-x86/
> arm/arm-linux-androideabi-4.7/bin/../lib/gcc/arm-linux-androideabi/4.7/../../
> ../../arm-linux-androideabi/bin/as: /lib64/libz.so.1: no version information
> available (required by
> /builds/slave/b2g_m-b30_14_dolphin_eng_dep-0/build/prebuilts/gcc/linux-x86/
> arm/arm-linux-androideabi-4.7/bin/../lib/gcc/arm-linux-androideabi/4.7/../../
> ../../arm-linux-androideabi/bin/as)
> 19:30:42     INFO -  target thumb C++: libbinder <=
> frameworks/native/libs/binder/Parcel.cpp
> 19:30:42     INFO -  frameworks/native/libs/binder/MemoryHeapIon.cpp:55:35:
> fatal error: usr/include/linux/ion.h: No such file or directory
> 19:30:42     INFO -  compilation terminated.
> 19:30:42     INFO -  make: ***
> [out/target/product/scx15_sp7715ga/obj/SHARED_LIBRARIES/
> libbinder_intermediates/MemoryHeapIon.o] Error 1
> 
> I've closed b2g30 until this gets unbroken. Or I can reopen and hide the
> Dolphin builds. What do we prefer?

Peipei - If these builds are down, then are you blocked on your testing? Or are you able to workaround this by using a Dolphin build provided elsewhere (e.g. TWCI)?
Flags: needinfo?(pcheng)
hmm, got some green retriggers. Can't help but notice that the 2 failed builds were both on b-linux64-hp slaves and the passing ones were on AWS spot slaves. So maybe this is a slave config issue?
Component: General → General Automation
Flags: needinfo?(catlee)
Product: Firefox OS → Release Engineering
QA Contact: catlee
(In reply to Jason Smith [:jsmith] from comment #1)
> (In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #0)
> > Presumably something in an outside repo changed, because it appears to have
> > recently broken even though I don't see any changes on our end.
> > 
> > https://tbpl.mozilla.org/php/getParsedLog.php?id=41261262&tree=Mozilla-B2g30-
> > v1.4
> > 
> > 19:30:42     INFO - 
> > /builds/slave/b2g_m-b30_14_dolphin_eng_dep-0/build/prebuilts/gcc/linux-x86/
> > arm/arm-linux-androideabi-4.7/bin/../lib/gcc/arm-linux-androideabi/4.7/../../
> > ../../arm-linux-androideabi/bin/as: /lib64/libz.so.1: no version information
> > available (required by
> > /builds/slave/b2g_m-b30_14_dolphin_eng_dep-0/build/prebuilts/gcc/linux-x86/
> > arm/arm-linux-androideabi-4.7/bin/../lib/gcc/arm-linux-androideabi/4.7/../../
> > ../../arm-linux-androideabi/bin/as)
> > 19:30:42     INFO -  target thumb C++: libbinder <=
> > frameworks/native/libs/binder/MemoryHeapBase.cpp
> > 19:30:42     INFO -  target thumb C++: libbinder <=
> > frameworks/native/libs/binder/MemoryHeapIon.cpp
> > 19:30:42     INFO - 
> > /builds/slave/b2g_m-b30_14_dolphin_eng_dep-0/build/prebuilts/gcc/linux-x86/
> > arm/arm-linux-androideabi-4.7/bin/../lib/gcc/arm-linux-androideabi/4.7/../../
> > ../../arm-linux-androideabi/bin/as: /lib64/libz.so.1: no version information
> > available (required by
> > /builds/slave/b2g_m-b30_14_dolphin_eng_dep-0/build/prebuilts/gcc/linux-x86/
> > arm/arm-linux-androideabi-4.7/bin/../lib/gcc/arm-linux-androideabi/4.7/../../
> > ../../arm-linux-androideabi/bin/as)
> > 19:30:42     INFO - 
> > /builds/slave/b2g_m-b30_14_dolphin_eng_dep-0/build/prebuilts/gcc/linux-x86/
> > arm/arm-linux-androideabi-4.7/bin/../lib/gcc/arm-linux-androideabi/4.7/../../
> > ../../arm-linux-androideabi/bin/as: /lib64/libz.so.1: no version information
> > available (required by
> > /builds/slave/b2g_m-b30_14_dolphin_eng_dep-0/build/prebuilts/gcc/linux-x86/
> > arm/arm-linux-androideabi-4.7/bin/../lib/gcc/arm-linux-androideabi/4.7/../../
> > ../../arm-linux-androideabi/bin/as)
> > 19:30:42     INFO -  target thumb C++: libbinder <=
> > frameworks/native/libs/binder/Parcel.cpp
> > 19:30:42     INFO -  frameworks/native/libs/binder/MemoryHeapIon.cpp:55:35:
> > fatal error: usr/include/linux/ion.h: No such file or directory
> > 19:30:42     INFO -  compilation terminated.
> > 19:30:42     INFO -  make: ***
> > [out/target/product/scx15_sp7715ga/obj/SHARED_LIBRARIES/
> > libbinder_intermediates/MemoryHeapIon.o] Error 1
> > 
> > I've closed b2g30 until this gets unbroken. Or I can reopen and hide the
> > Dolphin builds. What do we prefer?
> 
> Peipei - If these builds are down, then are you blocked on your testing? Or
> are you able to workaround this by using a Dolphin build provided elsewhere
> (e.g. TWCI)?

Jason, recent twci build does not has this problem. And I used these builds for test.
http://release1-qa.corp.tpe1.mozilla.com:8080/view/All.B2G.Build/job/B2G.v1.4.0.dolphin/
Flags: needinfo?(pcheng)
Okay - that means we're not blocked here. Feel free to reopen the tree & hide the builds then.
Done, thanks :)
You should build kernel before system image. It's OK on my side, the root cause is frameworks include kernel header file.
Flags: needinfo?(kli)
In my local build, it does work properly with
$ ./build.sh kernelheader && ./build.sh

I have a comment in bug 1011129 comment 17 to confirm do we build kernelheader first.
Flags: needinfo?(kli)
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #2)
> hmm, got some green retriggers. Can't help but notice that the 2 failed
> builds were both on b-linux64-hp slaves and the passing ones were on AWS
> spot slaves. So maybe this is a slave config issue?

If kernelheader is not built in-advanced, restart build a few times can finish build in green.
Severity: blocker → major
Flags: needinfo?(catlee)
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
Looking at the recent history on TBPL, we are still hitting this failure intermittently.
Status: RESOLVED → REOPENED
Component: General Automation → General
Product: Release Engineering → Firefox OS
QA Contact: catlee
Resolution: WORKSFORME → ---
No failed Dolphin builds since comment 11.
Assignee: nobody → ryanvm
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.0 S4 (20june)
Hi Ryan, 'kernelheader' is necessary for all Spreadtrum chipset device.
You need to log in before you can comment on or make changes to this bug.