Ensure fence delivery for non-tiled thebes layer in b2g process gonk

VERIFIED FIXED in Firefox 32, Firefox OS v2.0

Status

()

Core
Graphics: Layers
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: sotaro, Assigned: sotaro)

Tracking

({regression})

unspecified
mozilla33
ARM
Gonk (Firefox OS)
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.0+, firefox31 wontfix, firefox32 fixed, firefox33 fixed, b2g-v2.0 verified, b2g-v2.1 verified)

Details

Attachments

(4 attachments, 1 obsolete attachment)

(Assignee)

Description

4 years ago
gecko deliver fence object by best effort for TiledContentClient. There is a cases that it is not enough. We need to ensure fence delivery for TiledContentClient.

Basics of fence delivery ensuring is already implemented by Bug 1006957. I am going to use it.

On later master nexus-5, this problem could be easily produced the the following STR.
-[1] Start Setting app
-[2] move "Developer" ->"Debugging via USB ADB only"
-[3] On pop up window tousch "Disabled", ADB only and "ADB and DevTools" repeatedly until the problem happens.

If the problem does not happen, restart the Settings app.
(Assignee)

Comment 1

4 years ago
Created attachment 8436331 [details]
video when flickering happens
(Assignee)

Comment 2

4 years ago
On Bug 1006957, fence delivery ensuring is already implemented for un-tiled thebes layer, canvas layer and Image layer.
blocking-b2g: --- → 1.4?
(Assignee)

Comment 3

4 years ago
Nominate to b2g-v1.4. It is very bad user experience.
(Assignee)

Updated

4 years ago
Assignee: nobody → sotaro.ikeda.g
(Assignee)

Updated

4 years ago
Status: NEW → ASSIGNED
blocking-b2g: 1.4? → backlog
(Assignee)

Comment 4

4 years ago
I saw the problem also on QRD8X26.
(Assignee)

Comment 5

4 years ago
By the investigation the problem in comment 0 and Fence delivery for TiledLayer is independent problem. The problem happens on non-tiled thebes layer in chrome process(b2g). I am going to split "Ensure Fence delivery for TiledLayer" to a new bug.
(Assignee)

Updated

4 years ago
Summary: Ensure fence delivery for TiledContentClient on gonk → Ensure fence delivery for non-tiled thebes layer in b2g process gonk
(Assignee)

Comment 6

4 years ago
This is a regression of Bug 1006957.
Keywords: regression
(Assignee)

Updated

4 years ago
Blocks: 1006957
(Assignee)

Comment 7

4 years ago
(In reply to Sotaro Ikeda [:sotaro] from comment #6)
> This is a regression of Bug 1006957.

I already locally confirmed the fix on nexus-5.
(Assignee)

Comment 8

4 years ago
Created attachment 8442121 [details] [diff] [review]
patch - Ensure fence delivery of  thebes layer in b2g process

I confirmed the fix on master nexut-5.
(Assignee)

Updated

4 years ago
Attachment #8442121 - Flags: review?(nical.bugzilla)
(Assignee)

Comment 9

4 years ago
Re-nominate to b2g-v1.4. It becomes clear that the problem is regression of Bug 1006957. And the problem happens not only on nexus-5 and also on qcom's qrd device. 

By the problem, UIs that exist in chrome process(b2g process) could cause the problem like attachment 8436331 [details]. Confirmation window UI is one example of the cases.
(Assignee)

Updated

4 years ago
blocking-b2g: backlog → 1.4?
Can you please attach a screen shot? Given that its a regression and reproducible on several devices I'm keen to understand/ see the user impact.
Flags: needinfo?(sotaro.ikeda.g)
(Assignee)

Comment 11

4 years ago
Created attachment 8442202 [details]
symptom of qrd8x26

I was very difficult to take a screen shot and failed to get it. Instead, I attached a movie of QRD8x26. The touched item of left most area becomes totally transparent.
Flags: needinfo?(sotaro.ikeda.g)
Comment on attachment 8442121 [details] [diff] [review]
patch - Ensure fence delivery of  thebes layer in b2g process

Review of attachment 8442121 [details] [diff] [review]:
-----------------------------------------------------------------

gfxPlatform::UsesOffMainThreadCompositing() will always return true in these code paths, r=me if you remove it from the if()s.
Attachment #8442121 - Flags: review?(nical.bugzilla) → review+
(Assignee)

Comment 13

4 years ago
Created attachment 8442270 [details] [diff] [review]
patch v2 - Ensure fence delivery of thebes layer in b2g process(r=nical)

Apply the comment. Carry "r=nical".
Attachment #8442121 - Attachment is obsolete: true
(Assignee)

Updated

4 years ago
Attachment #8442270 - Attachment description: patch v2 - Ensure fence delivery of thebes layer in b2g process → patch v2 - Ensure fence delivery of thebes layer in b2g process(r=nical)
Attachment #8442270 - Flags: review+
There is significant flicker but I want to know if this happens only on the Settings App or other Apps as well?
Flags: needinfo?(sotaro.ikeda.g)
(Assignee)

Comment 16

4 years ago
(In reply to Preeti Raghunath(:Preeti) from comment #15)
> There is significant flicker but I want to know if this happens only on the
> Settings App or other Apps as well?

The flicker could happen also another app that uses chrome(b2g process) side UI.
Flags: needinfo?(sotaro.ikeda.g)
https://hg.mozilla.org/mozilla-central/rev/7a45df366ec8
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla33
Test team,

Please test the patch on master. Would like to take in 1.4 so waiting for analysis.
Keywords: verifyme
No-jun, do you mind taking a look at this patch fix on the next master build, and see if this patch 1) is fixed, and 2) has any repercussions anywhere else?    your analysis will help triage decide if this patch is low risk for 1.4 uplift.

Thanks!

Updated

4 years ago
Flags: needinfo?(npark)
Sotaro, I flashed the local build of gecko into my flame device, and although the original issue is no longer reproducible, i see the exact issue of Bug 1023506 happening again.  (the str is same, but more frequent once the orientation change is made)  Do you think they are related or would it be caused by something else?
Flags: needinfo?(npark) → needinfo?(sotaro.ikeda.g)
(Assignee)

Comment 21

4 years ago
(In reply to No-Jun Park [:njpark] from comment #20)
> Sotaro, I flashed the local build of gecko into my flame device, and
> although the original issue is no longer reproducible, i see the exact issue
> of Bug 1023506 happening again.  (the str is same, but more frequent once
> the orientation change is made)  Do you think they are related or would it
> be caused by something else?

I did not saw the problem on flame device. The problem happens more large display device. It happened on qrd8X26 and nexus-5. I do not have a madai device, it also seems to have large display, the problem could happen on it, I think.
Flags: needinfo?(sotaro.ikeda.g)
(Assignee)

Comment 22

4 years ago
> i see the exact issue of Bug 1023506 happening again.

Bug 1023506 seems different problem. It seems gallery app's problem.
Not a critical regression, so not blocking.
blocking-b2g: 1.4? → backlog

Updated

4 years ago
Duplicate of this bug: 1033588

Comment 25

4 years ago
It fixes Bug 1033588. Please land the patch in v2.0 branch as well.
Blocks: 1011657
blocking-b2g: backlog → 2.0?

Updated

4 years ago
blocking-b2g: 2.0? → 2.0+
https://hg.mozilla.org/releases/mozilla-aurora/rev/ad4ea249261a
status-b2g-v2.0: --- → fixed
status-b2g-v2.1: --- → fixed
status-firefox31: --- → wontfix
status-firefox32: --- → fixed
status-firefox33: --- → fixed

Comment 27

4 years ago
Cannot reproduce it on latest Flame KK build
Comment 21 mentioned, we need to verify this patch on Nexus-5 or Madai.
Status: RESOLVED → VERIFIED

Comment 28

4 years ago
cannot reproduce it on Madai build KAG07d_pre1
wait nexus-5 result

Comment 29

4 years ago
nexus-5 also cannot reproduce this problem
Gaia-Rev        2a612867039a7cfb3af6e692bfae4482b06705e9
Gecko-Rev       
Build ID        20140919143725
Version         34.0a2
Device Name     hammerhead
FW-Release      4.4.2
FW-Incremental  eng.mikel.20140918.154302
FW-Date         四  9月 18 15:43:31 CST 2014
Bootloader      HHZ11k
Keywords: verifyme
Created attachment 8531162 [details]
Verify_Video_Flame.MP4

This issue has been verified successfully on Flame 2.0 & 2.1.
See attachment: Verify_Video_Flame.MP4
Reproducing rate: 0/10

Flame v2.0 version:
Gaia-Rev        8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/c756bd8bf3c3
Build-ID        20141201000201
Version         32.0

Flame v2.1 version:
Gaia-Rev        ccb49abe412c978a4045f0c75abff534372716c4
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/18fb67530b22
Build-ID        20141201001201
Version         34.0
status-b2g-v2.0: fixed → verified
status-b2g-v2.1: fixed → verified
You need to log in before you can comment on or make changes to this bug.