If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

onmouseout never fires on html5 notifications (alert.xul)

RESOLVED INVALID

Status

()

Core
DOM: Events
RESOLVED INVALID
3 years ago
2 years ago

People

(Reporter: deltaburnt, Unassigned)

Tracking

32 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0 (Beta/Release)
Build ID: 20140606030206

Steps to reproduce:

On the latest Ubuntu, define an onmouseout event on a XUL document like alert.xul (the document that specifies how HTML5 notifications appear). Happens within a virtual machine (Ubuntu) and native install of Linux (Raspbian).

If you need any easy way to test this you can install my WIP extension: https://github.com/deltaburnt/BetterNotifications

Set alert display time in the options to about 10000, hover over a new notification and notice that the progress bar to the left stopped, then hover out and it doesn't continue. This is because onmouseout event is not firing.


Actual results:

The event is never fired.


Expected results:

It works perfectly on Windows as far as I can tell, and it appears to just never call the event I define.
(Reporter)

Updated

3 years ago
OS: Windows 8.1 → Linux

Comment 1

3 years ago
Could you perhaps attach a _minimal_ testcase
Keywords: testcase-wanted
(Reporter)

Updated

3 years ago
Summary: onmouseout never fires on borderless XUL documents → onmouseout never fires on html5 notifications (alert.xul)
(Reporter)

Comment 2

3 years ago
(In reply to Olli Pettay [:smaug] from comment #1)
> Could you perhaps attach a _minimal_ testcase

What is the optimal way of doing this? Would a small bootstrapped extension that creates an alert or console log in onmouseout work?

Comment 3

3 years ago
I guess that would work.
(Reporter)

Comment 4

3 years ago
It appears it actually is calling the function, it's just my tests were flawed. For some reason I couldn't log to console from those events. Sorry to waste your time.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
Keywords: testcase-wanted
You need to log in before you can comment on or make changes to this bug.