Closed Bug 1022235 Opened 6 years ago Closed 6 years ago

Intermittent 408431-1.html, 341963-1.html, test_peerConnection_throwInCallbacks.html, test_peerConnection_toJSON.html | application crashed [@ 0x2060be74][@ webrtc::ViEEncoder::~ViEEncoder()]

Categories

(Core :: WebRTC, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla33
Tracking Status
firefox30 --- unaffected
firefox31 --- unaffected
firefox32 --- fixed
firefox33 --- fixed
firefox-esr24 --- unaffected

People

(Reporter: RyanVM, Assigned: jesup)

References

Details

(Keywords: crash, intermittent-failure)

+++ This bug was initially created as a clone of Bug #1018372 +++

https://tbpl.mozilla.org/php/getParsedLog.php?id=41290473&tree=Mozilla-Inbound

Android 2.2 Armv6 Tegra mozilla-inbound opt test crashtest on 2014-06-07 12:22:41 PDT for push 650ea68d7ef2
slave: tegra-068

REFTEST TEST-END | http://10.26.84.14:30068/tests/dom/media/tests/crashtests/863929.html
REFTEST TEST-START | http://10.26.84.14:30068/tests/dom/src/offline/crashtests/408431-1.html
RESTORE PREFERENCE pref(media.navigator.permission.disabled,false)
REFTEST TEST-LOAD | http://10.26.84.14:30068/tests/dom/src/offline/crashtests/408431-1.html | 656 / 2659 (24%)
INFO | automation.py | Application ran for: 0:03:02.515947
INFO | zombiecheck | Reading PID log: /tmp/tmpXHD0pgpidlog
Contents of /data/anr/traces.txt:


mozcrash INFO | Downloading symbols from: http://ftp.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/mozilla-inbound-android-armv6/1402141355/fennec-32.0a1.en-US.android-arm-armv6.crashreporter-symbols.zip
PROCESS-CRASH | http://10.26.84.14:30068/tests/dom/src/offline/crashtests/408431-1.html | application crashed [@ 0x2060be74]
Crash dump filename: /tmp/tmpvWVgoT/45b769de-b397-ecd6-5c60e857-05fe1705.dmp
Operating system: Android
                  0.0.0 Linux 2.6.32.9-00002-gd8084dc-dirty #1 SMP PREEMPT Wed Feb 2 11:32:06 PST 2011 armv7l nvidia/harmony/harmony/harmony:2.2/FRF91/20110202.102810:eng/test-keys
CPU: arm
     2 CPUs

Crash reason:  SIGSEGV
Crash address: 0x2060be74

Thread 6 (crashed)
 0  0x2060be74
     r4 = 0x5d91db00    r5 = 0x00000000    r6 = 0x5d91db00    r7 = 0x5fe34000
     r8 = 0x5ccc14d0    r9 = 0x00000000   r10 = 0x5ccc14d0    fp = 0x00000000
     sp = 0x4f909750    lr = 0x556c22f8    pc = 0x2060be74
    Found by: given as instruction pointer in context
 1  libxul.so!webrtc::ViEEncoder::~ViEEncoder() [vie_encoder.cc:650ea68d7ef2 : 311 + 0x2]
     sp = 0x4f909768    pc = 0x556c2478
    Found by: stack scanning
 2  libxul.so!webrtc::ViEChannelManager::DeleteChannel(int) [vie_channel_manager.cc:650ea68d7ef2 : 293 + 0xe]
     r4 = 0x5ccc14a0    sp = 0x4f909770    pc = 0x556c27d8
    Found by: call frame info
 3  libxul.so!webrtc::ViEBaseImpl::DeleteChannel(int) [vie_base_impl.cc:650ea68d7ef2 : 216 + 0xa]
     r4 = 0x00000000    r5 = 0x5d91db00    r6 = 0x5d91c840    r7 = 0x4f90988f
     r8 = 0x4f2022e4   r10 = 0x00000001    sp = 0x4f9097b8    pc = 0x556c2a70
    Found by: call frame info
 4  libxul.so!mozilla::WebrtcVideoConduit::~WebrtcVideoConduit() [VideoConduit.cpp:650ea68d7ef2 : 108 + 0x12]
     r4 = 0x5d7cbc40    r5 = 0x00000000    r6 = 0x4f909854    r7 = 0x4f90988f
     r8 = 0x4f2022e4   r10 = 0x00000001    sp = 0x4f9097e0    pc = 0x54a03160
    Found by: call frame info
 5  libxul.so!mozilla::WebrtcVideoConduit::~WebrtcVideoConduit() [VideoConduit.cpp:650ea68d7ef2 : 136 + 0x2]
     r4 = 0x5d7cbc40    r5 = 0x00000000    r6 = 0x4f909854    r7 = 0x4f90988f
     r8 = 0x4f2022e4   r10 = 0x00000001    sp = 0x4f9097f8    pc = 0x54a032e4
    Found by: call frame info
 6  libxul.so!CSF::CC_Call::Release() + 0x2e
     r4 = 0x5d7cbc40    r5 = 0x00000000    r6 = 0x4f909854    r7 = 0x4f90988f
     r8 = 0x4f2022e4   r10 = 0x00000001    sp = 0x4f909800    pc = 0x549fbbe8
    Found by: call frame info
 7  libxul.so!mozilla::RefPtr<mozilla::AudioSessionConduit>::~RefPtr() + 0x16
     r4 = 0x59554f9c    r5 = 0x00000000    r6 = 0x4f909854    r7 = 0x4f90988f
     r8 = 0x4f2022e4   r10 = 0x00000001    sp = 0x4f909810    pc = 0x549fbc08
    Found by: call frame info
 8  libxul.so!mozilla::ConduitDeleteEvent::~ConduitDeleteEvent() [MediaPipeline.h:650ea68d7ef2 : 345 + 0x12]
     r4 = 0x59554f90    r5 = 0x00000000    r6 = 0x4f909854    r7 = 0x4f90988f
     r8 = 0x4f2022e4   r10 = 0x00000001    sp = 0x4f909818    pc = 0x54a0e940
    Found by: call frame info
 9  libxul.so!mozilla::ConduitDeleteEvent::~ConduitDeleteEvent() [MediaPipeline.h:650ea68d7ef2 : 345 + 0x6]
     r4 = 0x59554f90    r5 = 0x00000000    r6 = 0x4f909854    r7 = 0x4f90988f
     r8 = 0x4f2022e4   r10 = 0x00000001    sp = 0x4f909820    pc = 0x54a0e96c
    Found by: call frame info
10  libxul.so!PipUIContext::Release() [nsNSSComponent.cpp:650ea68d7ef2 : 1910 + 0xe]
     r4 = 0x59554f90    r5 = 0x00000000    r6 = 0x4f909854    r7 = 0x4f90988f
     r8 = 0x4f2022e4   r10 = 0x00000001    sp = 0x4f909828    pc = 0x54684db0
    Found by: call frame info
11  libxul.so!mozilla::RefPtr<mozilla::SharedThreadPool>::~RefPtr() + 0x1e
     r4 = 0x4f909854    r5 = 0x00000000    r6 = 0x4f909854    r7 = 0x4f90988f
     r8 = 0x4f2022e4   r10 = 0x00000001    sp = 0x4f909838    pc = 0x546755a4
    Found by: call frame info
Bug 1022212 backed out.
https://hg.mozilla.org/integration/mozilla-inbound/rev/ff91eb765497
Blocks: 1022212
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla32
Bug 1022212 re-landed and we're seeing these crashes again, but I've been assured that this is just another permutation of the other various 408431-1.html crashes currently being tracked and not a new issue in and of itself.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Depends on: 1022509
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #8)
> Bug 1022212 re-landed and we're seeing these crashes again, but I've been
> assured that this is just another permutation of the other various
> 408431-1.html crashes currently being tracked and not a new issue in and of
> itself.

Bug 1022212 backed out again, since these failures turn the previously green Android 4.0 debug m-6, not green.
Relanded those patches with edmorley's agreement, and disabled 408431-1 until root cause is backed out
https://hg.mozilla.org/integration/mozilla-inbound/rev/3b877866e65c
(In reply to Randell Jesup [:jesup] from comment #14)
> Relanded those patches with edmorley's agreement, and disabled 408431-1
> until root cause is backed out

I can't imagine the problem is with 408431-1 as much as it is with "whatever tests run right after the PeerConnection tests". This is almost guaranteed to do nothing other than make whatever test used to run right *after* 498431-1 start to crash...
We know the test disable doesn't fix or even guarantee avoiding the problem, and it may very well just move to a new bug that takes the blame for the GC problem.

We're waiting on a backout of the underlying problem (it's not a clean backout a sheriff can do).  We're hitting this in tests all over the tree, though it seems to have an affinity for webrtc tests and ViEEncoder in particular.  (As you might expect, GC bugs can hit lots of things, and they're very timing dependent - small changes like turning on LoadManager can dramatically affect the likelihood of triggering.)

This disable is very temporary (hope to re-enable today after root backout).
https://tbpl.mozilla.org/php/getParsedLog.php?id=41360098&tree=Mozilla-Central
Summary: Intermittent 408431-1.html | application crashed [@ 0x2060be74][@ webrtc::ViEEncoder::~ViEEncoder()] → Intermittent 408431-1.html, 341963-1.html | application crashed [@ 0x2060be74][@ webrtc::ViEEncoder::~ViEEncoder()]
Summary: Intermittent 408431-1.html, 341963-1.html | application crashed [@ 0x2060be74][@ webrtc::ViEEncoder::~ViEEncoder()] → Intermittent 408431-1.html, 341963-1.html, test_peerConnection_throwInCallbacks.html | application crashed [@ 0x2060be74][@ webrtc::ViEEncoder::~ViEEncoder()]
Summary: Intermittent 408431-1.html, 341963-1.html, test_peerConnection_throwInCallbacks.html | application crashed [@ 0x2060be74][@ webrtc::ViEEncoder::~ViEEncoder()] → Intermittent 408431-1.html, 341963-1.html, test_peerConnection_throwInCallbacks.html, test_peerConnection_toJSON.html | application crashed [@ 0x2060be74][@ webrtc::ViEEncoder::~ViEEncoder()]
Hrm, still seeing this on inbound, albeit lower frequency.
No longer depends on: 1022509
This was not fixed by the backout of billm's patch.
https://hg.mozilla.org/mozilla-central/rev/122bbadf6f74
Assignee: nobody → rjesup
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.