Closed Bug 1022239 Opened 5 years ago Closed 2 years ago

[Meta] Investigate whether Speedometer is a useful benchmark and if so, compare to other browsers and optimize Gecko when needed

Categories

(Core :: DOM: Core & HTML, defect)

29 Branch
x86_64
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1339557

People

(Reporter: smaug, Unassigned)

References

()

Details

On 64 bit linux Nightly gives 38 runs/min, Chromium 28.
But based on https://code.google.com/p/chromium/issues/detail?id=365446 would be good to get numbers on OSX and compare to Safari.

When looking at the source 
( https://github.com/WebKit/webkit/tree/master/PerformanceTests/Speedometer
or just the source code of http://browserbench.org/Speedometer/ ) it is a bit hard to see
what the whole thing is actually testing.
I was doing random profiling during the test run (at least during AngularJS and jQuery parts) and
self-time was mostly in JS.
HTML parser showed up a bit too. As far as I see, mostly http://mxr.mozilla.org/mozilla-central/source/parser/html/nsHtml5DocumentBuilder.h#56 doing appends to nsTArray 

I need to test with the patch for bug 902618.
On my Mac, I see numbers like so:

Chrome 37 dev: 46.2 ± 1.5 runs/min
WebKit nightly: 104.6 ± 0.60 runs/min
Firefox nightly: 58.2 ± 0.62 runs/min

For comparison, also,

Safari 7.0.4 release: 65.52 ± 0.60 runs/min
Firefox 29 release: 53.1 ± 7.8 runs/min (might be load issues on my machine; it had one 9 run/min run and a bunch in the 60+ range).

Profiling this is a pain, I bet, because it will include a bunch of load-time things that the benchmark doesn't include in the score.
bug 902618 doesn't seem to have any affect to the results.
Blocks: 1022714
See Also: → 1022988
Depends on: 1022988
See Also: 1022988
bz thinks Speedometer has a potential to test DOM perf better than Dormaeo does.

This might give it higher priority than other tests we're considering at bug  	1022714.
Blocks: 987136
Yeah, potential.
At least in the form speedometer was released it was basically testing
some innerHTML and DOM mutations related to <input> and js execution. So not too good.
But rniwa hinted speedometer would get some more tests, so the idea is to make it more useful.
(In reply to Avi Halachmi (:avih) from comment #4)
> This might give it higher priority than other tests we're considering at bug
> 1022714.

Ermm.. bug 1040081 (too long dependency chains...)
Olli, will you ping me when it becomes more useful then?
I'll try to remember to check https://github.com/WebKit/webkit/tree/master/PerformanceTests/Speedometer occasionally.
Doesn't look like it has been developed actively recently.
We are tracking Speedometer v2 work in bug 1339557.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: Speedometer_V2
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.