Manage sync is opening general tab of about:preferences page if sync settings are not set

RESOLVED WORKSFORME

Status

()

Firefox
Sync
--
major
RESOLVED WORKSFORME
4 years ago
2 years ago

People

(Reporter: Ashickur Rahman, Unassigned)

Tracking

32 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
I just tried to sync my firefox using my firefox account. After successful login I click the manage button. In the new tab about:preferences is opened but it shows general tab. More interestingly is shows sync tab with general tab content. 

But if you set the sync settings, it behaves normal.‌‌

For test case, please use fresh profile then test it.
(Reporter)

Comment 1

4 years ago
Created attachment 8436424 [details]
sync problem.png
(Reporter)

Comment 2

4 years ago
I checked it on Linux 32 bit build and Windows XP and safe mode, it remains same.
Severity: normal → major
OS: Linux → All
Hardware: x86_64 → All

Comment 3

4 years ago
Actually, this happens even if new sync is enabled.  The panel at the left has sync marked as the active tab, but the general tab is displayed.  You have to select a different tab, and then go back to sync, to get it.
(Reporter)

Comment 4

4 years ago
Isn't it a bug?

Comment 5

2 years ago
Can someone confirm if this is still an issue? Cannot reproduce- Firefox 47, Win8.1 32-bit build.
(In reply to Kurt Carpenter from comment #5)
> Can someone confirm if this is still an issue? Cannot reproduce- Firefox 47,
> Win8.1 32-bit build.

I can't repro either. In the screenshot the attachment just says "about:preferences" without a trailing #sync - I suspect it was some obscure other bug since fixed, but please reopen if you can still reproduce.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.