Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Status

Firefox Graveyard
Shumway
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: Yohann Jardin, Assigned: yury)

Tracking

({regression})

32 Branch
Firefox 33
x86_64
Windows 7
regression

Details

(Whiteboard: [shumway:m2])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0 (Beta/Release)
Build ID: 20140608030203

Steps to reproduce:

Go to http://www.areweflashyet.com/shumway/index.html


Actual results:

There is no button on the application.


Expected results:

A button at bottom right of the application named shumway should be there to allow the application to run.
(Reporter)

Updated

3 years ago
Component: Untriaged → Shumway
Confirmed, black screen over the content, 32.0a1 (2014-06-09) Win 7 x64
Blocks: 904346
Status: UNCONFIRMED → NEW
Ever confirmed: true
Thanks for the report. Is this with Shumway set up and other Flash content working, or just with a clean profile? Testing on Windows 8 with a clean profile, both FF30 and today's Nightly work as expected.
(In reply to Paul Silaghi, QA [:pauly] from comment #1)
> Confirmed, black screen over the content, 32.0a1 (2014-06-09) Win 7 x64
Clean profile, set shumway.disabled=FALSE
Black screen over the plugin content on:
http://www.areweflashyet.com/shumway/index.html
http://www.miniclip.com/games/en/
(Reporter)

Comment 4

3 years ago
(In reply to Till Schneidereit [:till] from comment #2)
> Is this with Shumway set up and other Flash content
> working, or just with a clean profile?


Facing the issue on both.
Yury, can you look into this? It apparently blocks mwobensmith's work.
Flags: needinfo?(ydelendik)
I see this on latest Fx33 as well. 

I'm using a build of Fx32 from 2014-05-28 that seems to be OK, so it might be worthwhile to look for a regression range.
status-firefox32: --- → affected
status-firefox33: --- → affected
Whiteboard: [shumway:m2]
(Assignee)

Comment 7

3 years ago
Last good nightly: 2014-06-06
First bad nightly: 2014-06-07

Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c8288d0c7a15&tochange=62d33e3ba514
I tried to bisect archived mozilla-inbound builds between 2014-06-06 and 2014-06-07 using mozregression. I saw the "black screen" problem Paul reported in comment 1, but not the "no shumway button" problem.

When the Shumway instance is black, the following error logged to stderr:

> ShumwayStreamConverter.js: Timeout during shumway instance initialization

I'm using Shumway version 0.8.377. I bisected the blank Shumway instance problem to this regression range (that overlaps, but is not a subset of Yury's pushlog in comment 7). I'm testing OS X, if that makes a difference.

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=51b428be6213&tochange=58f1f6dbe7ce
status-firefox31: --- → unaffected
tracking-firefox32: --- → ?
Keywords: regression
(Assignee)

Comment 9

3 years ago
Created attachment 8444653 [details] [diff] [review]
Fixes XRays regression at ShumwayStreamConverter

https://github.com/mozilla/shumway/pull/1403
Attachment #8444653 - Flags: review?(till)
Flags: needinfo?(ydelendik)
Comment on attachment 8444653 [details] [diff] [review]
Fixes XRays regression at ShumwayStreamConverter

Review of attachment 8444653 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for fixing this.
Attachment #8444653 - Flags: review?(till) → review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
https://hg.mozilla.org/integration/mozilla-inbound/rev/bc61c38531da
Assignee: nobody → ydelendik
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/bc61c38531da
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 33
status-firefox32: affected → wontfix
status-firefox33: affected → fixed
tracking-firefox32: ? → -
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.