Enable newtab page for first tab in new window (including browser startup)

RESOLVED DUPLICATE of bug 725579

Status

()

Firefox
New Tab Page
--
enhancement
RESOLVED DUPLICATE of bug 725579
4 years ago
4 years ago

People

(Reporter: Greg Colyer, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
New tabs open with browser.newtab.url, which defaults to about:newtab. The thumbnails on this page can be disabled/enabled by clicking the "grid" icon, or browser.newtab.url can be changed manually, e.g. to about:blank (which would replicate previous behaviour).

However, this does not apply to the first tab in a new window, including at browser startup. If browser.startup.page is zero, then the first tab in a new window is about:blank. It would be cleaner and more consistent to update this also to use browser.newtab.url instead. (A new option for browser.startup.page could be added, but given the flexibility already provided as above, I think it would be fine to use the existing option zero, and it would not even be necessary to change UI.)

There is some recent related discussion under SeaMonkey bug 200956.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 725579
You need to log in before you can comment on or make changes to this bug.