Closed Bug 1022413 Opened 6 years ago Closed 6 years ago

Update list of languages supported by automatic translation

Categories

(Firefox :: Translation, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 33
Tracking Status
firefox32 --- fixed
firefox33 --- fixed

People

(Reporter: Felipe, Assigned: Felipe)

References

Details

(Whiteboard: p=1 s=33.1 [qa-])

Attachments

(1 file)

Currently we have a list of supported languages that was picked from bug 977743. The list is: En, Zh, Ja, Es, De, Fr, Ru, Ar, Ko, or Pt

We should think about updating the list based on what our provider supports (which is a lot more), to at least include Italian and Czech since the trial is targeted at European users. Also maybe Dutch, Swedish, Hungarian, Romanian..

See http://en.wikipedia.org/wiki/Languages_of_the_European_Union#Knowledge for most common languages in EU, and http://www.bing.com/translator/help/ for the languages supported by the provider.
Flags: firefox-backlog+
Whiteboard: p=0 [qa-]
Whiteboard: p=0 [qa-] → p=1 [qa-]
Assignee: nobody → mdeboer
Status: NEW → ASSIGNED
Whiteboard: p=1 [qa-] → p=1 s=33.1 [qa-]
Chad, what's your opinion on the suggestion in comment 0?

A technical limitation is that we can't yet support right-to-left languages, as we need to invest more resources for testing and probable resulting development.

It'd be awesomest if you could provide a list of locales to add, filtered by the support of our current provider, Bing.
Flags: needinfo?(cweiner)
Mike--for the purposes of the trial period, let's keep the current minimum set of supported languages represented in bug 977743 bug 977742 and bug 977744.  Those recommendations were based on our understanding of users content consumption habits and as we don't yet know much about usage of the feature, we can keep it constrained for the trial period.  If/when we support global release of the feature in more and more channels, we can revisit the supported language pairs.  Thanks!
Flags: needinfo?(cweiner)
(In reply to Chad Weiner from comment #2)
> Mike--for the purposes of the trial period, let's keep the current minimum
> set of supported languages represented in bug 977743 bug 977742 and bug
> 977744.

If I understood correctly, the point of this bug is to update the lists so that they make sense to a German audience, as that's where we plan to do a pre-trial with the aurora channel (bug 1022411). Are you sure our current list of language pairs is usable by German users (note: German isn't currently in the list of target languages)?
Flags: needinfo?(cweiner)
I talked with Chad, here's a summary:

- we want to start with a small set of languages now until we understand better how the usage is gonna be. On every new iteration of the trial we can analyze the data and have a better informed decision on how much to expand the list.
- let's remove Arabic for now from the list because the engine needs a bit more work for RTL
- the list of supported target languages should mirror the list of source languages
- The FHR code that collects languages detected only collects them after filtering happens, but this is wrong. It should collect detected languages even for languages that are not in the supported list. I'll file a separate bug about this.
Flags: needinfo?(cweiner)
Attached patch Update listSplinter Review
Since this is trivial, I hope you don't mind me stealing while you're working in the mock server.
I sorted the listed alphabetically in German. I'll open a bug about sorting it alphabetically in the browser's locale.
Assignee: mdeboer → felipc
Attachment #8442321 - Flags: review?(mdeboer)
Attachment #8442321 - Flags: review?(mdeboer) → review+
Comment on attachment 8442321 [details] [diff] [review]
Update list

[Approval Request Comment]
Bug caused by (feature/regressing bug #): This bug is part of the automatic translation feature, which we want to A/B with a subset of Aurora 32 users.
User impact if declined: List of supported translation languages will be incorrect
Testing completed (on m-c, etc.): landed on inbound
Risk to taking this patch (and alternatives if risky): none, trivial patch
String or IDL/UUID changes made by this patch: none
Attachment #8442321 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/365cb4e9c5ae
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 33
Comment on attachment 8442321 [details] [diff] [review]
Update list

Aurora approval granted.
Attachment #8442321 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Depends on: 1046142
I updated our feature and testing pages with the current list of languages: https://wiki.mozilla.org/QA/Translation.
Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.